| zzsir 回复于:2003-02-21 13:40:42 |
| 111 |
| liudw 回复于:2003-02-21 14:01:29 |
| sql1和sql2是安装在一台电脑上吗?如果是需要多大的内存? |
| aile 回复于:2003-02-21 20:00:38 |
| 装载同一台电脑上,每个虚拟机用128M,我的电脑是384M内存 |
| 南非蜘蛛 回复于:2003-02-21 20:48:24 |
| [quote:167503bf3a="aile"]装载同一台电脑上,每个虚拟机用128M,我的电脑是384M内存[/quote:167503bf3a]
等我有了好机器,要好好搞搞这个东西 |
| l63 回复于:2003-02-21 21:37:44 |
| 你的dc在那里 |
| l63 回复于:2003-02-21 21:40:39 |
| 你的12和17有点问题啊
我做了,专门一台机器作dc |
| aile 回复于:2003-02-21 21:41:58 |
| 用第一个节点做主域控制器,第二个节点加入域就行了。 |
| 78020281 回复于:2003-02-21 21:58:04 |
| 没有这么多内存呀。全部装nt4 吧。嘿嘿。 |
| aile 回复于:2003-02-21 22:02:12 |
| 下面网址是安装Windows 2000群集服务的指南,在vmware里除了要虚拟一个共享存储磁盘外,其他的与在两台真实机器+阵列柜上装是一样的。
http://www.microsoft.com/china/technet/windows2000/200001/clustep.asp |
| 南非蜘蛛 回复于:2003-02-21 22:02:31 |
| 看来我需要找个server,装个linux版的了 |
| kenchu 回复于:2003-02-21 23:23:58 |
| 请问你的host os是windows 还是 linux 啊? |
| aile 回复于:2003-02-22 07:59:37 |
| Windows版,Linux版做法是一样的. |
| albeta 回复于:2003-02-24 09:57:52 |
| 搂主只说了怎么安装群集服务,能不能再介绍一下怎么实现其它软件的群集啊,比如说sql Server,IIS什么的,怎么实现负载均衡。怎么让服务器以active/active模式启动,而不是active/passive模式。 |
| liudw 回复于:2003-02-24 13:47:51 |
| 那网卡是怎么样确定的?作群集至少需要2块网卡的,我的电脑上只有一块网卡,该怎么办?能详细的说说吗?谢谢 |
| laoxia 回复于:2003-02-24 20:07:08 |
| 群集是啥?(认真地) |
| liudw 回复于:2003-02-24 23:05:28 |
| 这是我的文件内容,请问我该怎么改?谢谢
config.version = "6" virtualHW.version = 2 localConsole = TRUE displayName = "solaris2" draw = "gdi" guestOS = "other" ide0:0.present = TRUE ide0:0.fileName = "Other.vmdk" ide1:0.present = TRUE ide1:0.deviceType = "cdrom-raw" ide1:0.fileName = "D:" memsize = 128 ethernet0.present = TRUE floppy0.present = FALSE ethernet1.present = TRUE uuid.location = "56 4d ff b6 2a f4 af 42-49 e2 21 1e b2 bb 5f 8a" |
| aile 回复于:2003-02-25 07:21:07 |
| VMWAR里可以虚拟两块网卡,不需要有真实的网卡。
常见服务安装:http://www.jite.net/zygc/4/particular.php?page=4.7 |
| aile 回复于:2003-02-25 07:23:34 |
| liudw把文章里写的那几行加进去就行了。 |
| ORA-600 回复于:2003-02-25 09:55:59 |
| 我曾经在vmware上安装了ORACLE OPS(linux),也写了篇粗略的文档,可是这里是solaris论坛,发在这里不合适哦? |
| liudw 回复于:2003-02-25 12:08:50 |
| 谢谢,我搞定了,但我觉得最好是在vmware图形里面添加,我直接修改.vmx时我的无法启动 |
| shimu 回复于:2003-02-25 15:29:06 |
| [quote:fd747deac6="ORA-600"]我曾经在vmware上安装了ORACLE OPS(linux),也写了篇粗略的文档,可是这里是solaris论坛,发在这里不合适哦? 简直是精品,发啊,感谢 |
| aile 回复于:2003-02-25 21:49:23 |
| 期待ORA-600的文章 |
| shimu 回复于:2003-02-25 22:09:37 |
| 安装win集群时找不到共享scsi |
| ORA-600 回复于:2003-02-26 11:19:12 |
| 很久不用了,凭着印象补充的,有错误的地方请指正。
安装VMWARE GSX SERVER, 创建两个Linux VM,每个单SCSI盘(SCSI 0),6个G,双网卡,一个Bridge,一个Host Only,ip地址自己设定了。 用plainmaker创建裸设备,最好创建创建2个2GB的,将创建的裸设备分别添加到两个VM上, 修改VM配置文件,将两个裸设备置于SCSI 1上,共享SCSI 1通道,disk.locking=false,scsi1.sharedBus = "virtual" 等等了,详细设置在VMWARE文档里有http://www.vmware.com/support/gsx2/doc/ha_configs_scsi-res_enable_gsx.html,很简单的。 以下是安装Oracle的步骤,有关问题见文档http://www.linuxeden.com/edu/doctext.php?docid=2308 1.安装Redhat 7.2(Server)和相应的补丁包(删除原来的binutils,安装7.1的binutils)#可以装xfce来做X界面 2.配置Hostname,修改/etc/hosts.equiv和$USERS/.rhosts,保证rsh,rcp能正确执行 3.对共享磁盘分区(一边就可以) 4.用raw绑定磁盘分区(或修改/etc/sysconfig/rawdevices,启动rawdevices服务) 5.修改/etc/rc.local,添加/sbin/insmod softdog soft_margin=60,启动softdog 6.创建ORACLE用户,在/etc/profile.d/oracle.sh里添加ORACLE的环境变量,SID不一样,SID1,SID2 7.在一边安装ORACLE,安装时选上OPS。 8.安装顺利,Link到96%是出现ins_rdbms.mk的错误,修改$ORACLE_HOME/lib/sysliblist -ldl -lm -lnsl -lpthread 9.rcp $ORACLE_HOME/lib/*到另一计算机上 10.出现运行root.sh时不要运行,在两边分别执行glibc-stubs的补丁包 11.修改root.sh里的错误,执行 12.修改$ORACLE_HOME/oracm/admin/nmcfg.ora,配置watchdogd,oranm,oracm CmHostName=dbsnode1 #dbsnode2上为dbsnode2 DefinedNodes=dbsnode1 dbsnode2 CmDiskFile=/dev/raw/raw1 13.以root启动watchdogd,oranm,oracm cd $ORACLE_HOME/oracm/bin ./watchdogd -g dba & ./oranm </dev/null>$ORACLE_HOME/oracm/log/nm.log 2>&1 & ./oracm </dev/null>$ORACLE_HOME/oracm/log/cm.log 2>&1 & 14.dbassist创建集群数据库,为每个表空间分配裸设备 15.修改/etc/oratab文件 16.修改两边listener.ora文件,启动listener 17.svrmgrl分别启动两边的数据库 注:最好能重新编译内核,将watchdog的nowayout加上,不然,一边shutdown以后,另一台1分钟后也会shutdown |
| scohk 回复于:2003-02-26 11:29:16 |
| 不知道。 |
| shimu 回复于:2003-02-26 12:47:29 |
| [quote:f6fd5b2110="ORA-600"]很久不用了,凭着印象补充的,有错误的地方请指正。
安装VMWARE GSX SERVER, 创建两个Linux VM,每个单SCSI盘(SCSI 0),6个G,双网卡,一个Bridge,一个Host Only,ip地址自己设定了。 用plainmaker创建裸设备..........[/quote:f6fd5b2110] 这么多好人感激! |
| shimu 回复于:2003-02-26 15:05:21 |
| [quote:ff67f8703d="ORA-600"]很久不用了,凭着印象补充的,有错误的地方请指正。
安装VMWARE GSX SERVER, 创建两个Linux VM,每个单SCSI盘(SCSI 0),6个G,双网卡,一个Bridge,一个Host Only,ip地址自己设定了。 用plainmaker创建裸设备..........[/quote:ff67f8703d] 这么多好人感激! |
| lyric 回复于:2003-03-09 13:33:43 |
| 哪有GSX SERVER 下? |
| l63 回复于:2003-03-09 16:19:35 |
| [quote:bd547e7476="aile"]用第一个节点做主域控制器,第二个节点加入域就行了。[/quote:bd547e7476]
晕倒, 这也行啊; 第一台dc的域角色和其他dc是不一样的; 一旦down,其他机器怎么入域;角色迁移吗?不够费事得; 怀疑~!!·· |