棘手的问题,关于vxfs

发表于:2007-06-09来源:作者:点击数: 标签:
我使用volumemanager作卷,2.6T的t3阵列使用volumemanager作了1.2t的raid0+1。然后我使用命令作vxfs的文件系统vxfs版本为3.5。根据3。5版本的说明,支持文件系统大小打到了32t。但是我使用命令mkfs-Fvxfs-oversion=5/dev/vx/rdsk/adg/vol01出错,错误提示为s

我使用volume manager作卷,2.6T的t3阵列使用volume manager作了1.2t的raid 0+1。然后我使用命令作vxfs的文件系统vxfs版本为3.5。根据3。5版本的说明,支持文件系统大小打到了32t。但是我使用命令mkfs -F vxfs -o version=5 /dev/vx/rdsk/adg/vol01 出错,错误提示为 sector must positive and <=68719472624(1T)。如果我使用命令
mkfs -F vxfs -o version=5 /dev/vx/adg/vol01 1200g,没有报错,但是作了文件系统后,挂接系统时候还汇报错。
mount -F vxfs /dev/vx/dsk/adg/vol01 /u01
错误信息为 layout is not support by this version of vxfs 。
那位见到过这样的问题,帮忙看看。我该怎办?

 mmmmn 回复于:2002-11-11 21:29:57
你自己的 solaris是什么版本?
还有打patch了吗?

 YT 回复于:2002-11-11 21:30:39
vxfs版本为3.5?是不是build 5 啊?


 x3y4z5 回复于:2002-11-11 21:37:31
我的操作系统8,推荐的补丁打过了。我查找了3.5的说明,好像不需要打额外的补丁了。我联系过veritas公司的支持,他们也说问题很怪?可能明天给我答复。今天为了它,我上班没时间上来看看。我仅仅通过命令察看了版本为3.5,至于build 5?我不懂了。。。

 mmmmn 回复于:2002-11-11 21:44:10
明天把答案写出来

 x3y4z5 回复于:2002-11-11 21:46:09
有了结果肯定上报大家知道。

 mmmmn 回复于:2002-11-11 21:47:16
:)

 YT 回复于:2002-11-11 21:59:15
pkginfo -l VRTSvxfs
结果给我看看。

 x3y4z5 回复于:2002-11-11 22:02:17
 PKGINST:  VRTSvxfs
      名称:  VERITAS File System
      种类:  system,utilities
      ARCH:  sparc
      版本:  3.5,REV=GA06
   BASEDIR:  /
    供应商:  VERITAS Software
      DESC:  Commercial File System
    PSTAMP:  VERITAS-3.5FS-2002-06-13
  INSTDATE:  Oct 17 2002 16:24
   HOTLINE:  (800) 342-0652
     EMAIL:  [email protected]
      状态:  全部安装
      文件:      258 installed pathnames
                  29 shared pathnames
                   5 linked files
                  46 directories
                  58 executables
                   5 setuid/setgid executables
               26432 blocks used (approx)


 YT 回复于:2002-11-11 22:06:56
直接mkfs -F vxfs /dev/vx/adg/vol01 1200g不行的吗?
不好意思我还没有拿到version5的VXFS。

 x3y4z5 回复于:2002-11-11 22:12:28
根据vxfs 3.5的说明,默认的mkfs -F使用的就是version=5选项。我实验过你说的命令。根据我的观察,只要使用了size的值,可以进行mkfs,但是在mount的步骤中就会出现上面提到的错误this layout is not supported by this version of vxfs

 YT 回复于:2002-11-11 22:19:40
!!不会是SUN OS 对VERSION 5的支持有问题吧?

 YT 回复于:2002-11-11 22:25:07
[这个贴子最后由YT在 2002/11/11 10:31pm 编辑]

这问题在cluster的时候出现过,就是
在VxFS 3.5下面fsck -o mounted fails
Veritas给的办法是在所有的nodes上安装 binaries

1. Copy S01VXFSLDLIC to /etc/rc2.d
2. Copy vxenablef to /opt/VRTSvxfs/sbin/
3. Copy vxenablef to /opt/VRTS/bin/
4. chmod +x /opt/VRTS/bin/vxenablef
5. Reboot all the nodes.

可参考以下:
cp /ws/suncluster/Products/Veritas/VxFS/3.5_sol_062602/4713594/S01VXFSLDLIC
/etc/rc2.d

cp /ws/suncluster/Products/Veritas/VxFS/3.5_sol_062602/4713594/vxenablef
/opt/VRTSvxfs/sbin

cp /opt/VRTSvxfs/sbin/vxenablef /opt/VRTS/bin/

reboot
试试如何?


 x3y4z5 回复于:2002-11-12 09:13:02
没做过cluser,那里可以找到相关的文件啊?

 YT 回复于:2002-11-12 11:28:55
在sunsolve.sun.com

 YT 回复于:2002-11-12 13:22:09
1. 在Normal Disk Create a slice(about 500m)
2. make vxfs on the slice
3. if you can mount the slice the the problem is the VxVm
4. check your VxVm Layout 

以上资料由phoenixli MM友情提供,估计错不了。

 x3y4z5 回复于:2002-11-12 14:41:12
我在这个卷上作文件系统,如果〈1024g(1T)就可以做,可以mount ,可以使用。但是只要到了1024T或者超过它,就会报错。555555555555。。。。。

 YT 回复于:2002-11-12 15:26:37
那应该是VxFS的问题吧。。。

 phoenixli 回复于:2002-11-12 18:50:31
在做测试,等一下告诉你答案.

 phoenixli 回复于:2002-11-12 19:05:17
/usr/lib/fs/vxfs/mkfs -F vxfs -o inosize=512 ninode=0 largefiles /dev/vx/rdsk/adg/vol01
 
看man的册,主要的增加inode的size.


 phoenixli 回复于:2002-11-12 19:06:39
x3y4z5在不在啊?赶紧试一下,我们在加班做测试哪.

 YT 回复于:2002-11-12 19:09:16
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 07:06pm[/i] 发表的内容:[/b]
x3y4z5在不在啊?赶紧试一下,我们在加班做测试哪.
[/quote]

你可真厉害。。。。。  
有一堆SPARC的人就是不一样。
唉!

 phoenixli 回复于:2002-11-12 19:10:31
/usr/lib/fs/vxfs/mkfs -F vxfs -o inosize=512 ninode=0 largefiles /dev/vx/rdsk/adg/vol01

看man的册,主要的增加inode的size.

512改成1024可以做8个T,快点啊,否则不等你了.


 phoenixli 回复于:2002-11-12 19:15:20
不等了,有结果再说吧.应该是这样做完以后问题就可以解决.

 YT 回复于:2002-11-12 20:12:19
我就没有办法试了。。。
x3y4z5你的结果如何?

 phoenixli 回复于:2002-11-12 20:21:05
这人半天没动静,也不知道在不在.

 daemonix 回复于:2002-11-12 20:25:48
有phoenixli mm在,连做实验环境都有了,好啊,手下还有一班高手,是本坛的福气啊。
辛苦了。 :-)


 phoenixli 回复于:2002-11-12 20:31:06
老兄,你是在恭维我还是讽刺我啊?我怎么觉得有点不对劲,意思是说我自己技术不怎么样,就只是手下有一班高手而已,是不是啊?

 phoenixli 回复于:2002-11-12 20:35:25
再说,我可是觉得这还算是个问题才让我的技术去解答的,那个出问题的家伙怎么找不着了,让大家等结果,真是.

 daemonix 回复于:2002-11-12 20:37:03
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 08:31pm[/i] 发表的内容:[/b]
老兄,你是在恭维我还是讽刺我啊?我怎么觉得有点不对劲,意思是说我自己技术不怎么样,就只是手下有一班高手而已,是不是啊?
[/quote]
我哪敢讽刺你啊,你老是疑神疑鬼的,你这两天心情蛮好的嘛 :)

 phoenixli 回复于:2002-11-12 20:40:45
不是讽刺就好,那我就全当恭维了.

 daemonix 回复于:2002-11-12 20:47:56
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 07:05pm[/i] 发表的内容:[/b]
/usr/lib/fs/vxfs/mkfs -F vxfs -o inosize=512 ninode=0 largefiles /dev/vx/rdsk/adg/vol01
 
看man的册,主要的增加inode的size.
[/quote]

VP还知道的如此具体,PF
就是嘴巴太厉害了,^_^

 YT 回复于:2002-11-12 20:56:21
[quote][b]下面引用由[u]daemonix[/u]在 [i]2002/11/12 08:47pm[/i] 发表的内容:[/b]
VP还知道的如此具体,PF
就是嘴巴太厉害了,^_^
[/quote]

同感,特怕她。。。  

 daemonix 回复于:2002-11-12 21:00:09
其实,我觉得VP大可不必知道的那么具体,在她手下干活,工程师只能去move box了,真的要累的吐血啊。
:)

 phoenixli 回复于:2002-11-12 21:01:37
deamonix,错啦,我事先都说过了,我是不懂技术的,你难道没有看见吗?

 daemonix 回复于:2002-11-12 21:05:02
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 09:01pm[/i] 发表的内容:[/b]
deamonix,错啦,我事先都说过了,我是不懂技术的,你难道没有看见吗?
[/quote]

看你把fsck的参数用的那么x,还说不懂技术,把我们当傻子啊?
虽然我是菜鸟,还是能知道你是高人啊,仰慕ing 

 phoenixli 回复于:2002-11-12 21:10:25
拜托,我都说了我是让我们技术解答了,不理你了.
楼主,试出结果来没有?大家都等着哪.

 daemonix 回复于:2002-11-12 21:12:31
让你的手下吃饭吧,我都心疼他们了,呵呵

 phoenixli 回复于:2002-11-12 21:15:14
早走啦.只有我还没有吃饭.

 x3y4z5 回复于:2002-11-12 21:15:21
我刚回来,是的结果如下:
./mkfs -F vxfs -o inosize=512,ninode=0,largefiles /dev/vx/rdsk/datadg/vol01
UX:vxfs mkfs: ERROR: sectors must be positive and <= 68719472624 (1 TB)
UX:vxfs mkfs: TO FIX: Usage:
  mkfs [-F vxfs] [-V] -m special
  mkfs [-F vxfs] [-V] [-o [N] [ninode=#] [bsize=#] [logsize=#]
                          [nau=#] [ausize=#] [aufirst=#] [aupad=#] [inosize=#]
                          [version=#] [quota|noquota|usrquota|grpquota] [align=#]
                          [largefiles|nolargefiles]
                          special size


 daemonix 回复于:2002-11-12 21:17:34
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 09:15pm[/i] 发表的内容:[/b]
早走啦.只有我还没有吃饭.
[/quote]

唉,VP掉进这里,也很惨啊。

 phoenixli 回复于:2002-11-12 21:20:17
[quote][b]下面引用由[u]x3y4z5[/u]在 [i]2002/11/12 09:15pm[/i] 发表的内容:[/b]
我刚回来,是的结果如下:
./mkfs -F vxfs -o inosize=512,ninode=0,largefiles /dev/vx/rdsk/datadg/vol01
UX:vxfs mkfs: ERROR: sectors must be positive and <= 68719472624 (1 TB)
UX:vxfs mkfs: TO FIX ...
[/quote]
我不太懂,是没问题了是吗?

 daemonix 回复于:2002-11-12 21:23:10
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 09:20pm[/i] 发表的内容:[/b]
我不太懂,是没问题了是吗?
[/quote]
看你,又装蒜了, :)

 x3y4z5 回复于:2002-11-12 21:24:28
不是。结果是要做的文件系统的大小必须小于<= 68719472624 (1 TB) 。我的卷的大小为1.2t。如果我制定的大小小于1t,就可以做,否则作了文件系统后,在mount的时候会报错
the layout is not supported by this version of vxfs.

 phoenixli 回复于:2002-11-12 21:26:58
你再等一下,再试一下,等会儿再给你一个结果.

 daemonix 回复于:2002-11-12 21:26:59
唉,为了0.2T,看惹出多大的麻烦,得不偿失!!!!
还不如让phoenixli mm送你200G算了 :)

 x3y4z5 回复于:2002-11-12 21:46:07
今天我还实验过命令./mkfs -F vxfs -o bsize=8192 /dev/vx/rdsk/datadg/vol01
结果还是不行。只好等到明天再看了。实在不行我只有作1t的文件系统了。

 phoenixli 回复于:2002-11-12 21:47:39
楼主,你有没有邮件?我把接下来怎么做告诉你,我不想发到这个烂论坛上来,版主都在利用特权乱搞,有什么好玩的?快,想解决问题就给我一个邮件.

 mmmmn 回复于:2002-11-12 21:48:59
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 09:47pm[/i] 发表的内容:[/b]
楼主,你有没有邮件?我把接下来怎么做告诉你,我不想发到这个烂论坛上来,版主都在利用特权乱搞,有什么好玩的?快,想解决问题就给我一个邮件.
[/quote]
这个。。。。。怎么能乱搞,麻烦告诉我一声,我一直想但没那个本事,西西

 phoenixli 回复于:2002-11-12 21:50:41
[这个贴子最后由phoenixli在 2002/11/16 07:01pm 编辑]

改帖子,封别人的发言,是不是你们干的事?自己去看看.

 daemonix 回复于:2002-11-12 21:51:32
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 09:47pm[/i] 发表的内容:[/b]
乱搞,有什么好玩的?快
[/quote]
什么意思啊? ^_^  :)

 mmmmn 回复于:2002-11-12 21:54:18
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 09:50pm[/i] 发表的内容:[/b]
改帖子,封别人的发言,是不是你们干的事?自己去看看,小心我找人把你这个论坛都封了,别忘了,老子有的是钱.
[/quote]
呵呵,不知道你又哪里不满意了,不过威胁的话讲出来就没意思了。
如果你真想行动就随便好了,我从来就不怕(不是我的论坛:)
而且你也一定封不了的:)

 x3y4z5 回复于:2002-11-12 21:55:27
大家消消火,这里是技术论坛,百家争鸣,对事不对人。我还在等着解决问题的办法呢。

 daemonix 回复于:2002-11-12 21:56:49
phoenixli,怎么搞的,又动火了?玩玩而已,别当真

 phoenixli 回复于:2002-11-12 22:00:38
[quote][b]下面引用由[u]mmmmn[/u]在 [i]2002/11/12 09:54pm[/i] 发表的内容:[/b]
呵呵,不知道你又哪里不满意了,不过威胁的话讲出来就没意思了。
如果你真想行动就随便好了,我从来就不怕(不是我的论坛:)
而且你也一定封不了的:)
[/quote]
装傻是不是?
楼主,查一下你的E-MAIL,不过有一条,不许把结果贴出来.

 daemonix 回复于:2002-11-12 22:01:52
to phoenixli:

给我也发一份吧,3ks!

 phoenixli 回复于:2002-11-12 22:02:36
[quote][b]下面引用由[u]daemonix[/u]在 [i]2002/11/12 09:56pm[/i] 发表的内容:[/b]
phoenixli,怎么搞的,又动火了?玩玩而已,别当真
[/quote]
你没看见是吗?黑寡妇干的好事

 phoenixli 回复于:2002-11-12 22:04:17
楼主,有结果发MESSAGE给我,如果还不行我叫人一定帮你解决.
实在不行告诉主机的IP,root的口令,telnet过去看看。没什么大不了的问题。

 daemonix 回复于:2002-11-12 22:06:49
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/12 10:02pm[/i] 发表的内容:[/b]
你没看见是吗?黑寡妇干的好事
[/quote]
这样说话,就是你的不对了,虽然我们也曾经吵过,但是过去的就过去了,何必动火呢?


 phoenixli 回复于:2002-11-12 22:10:48
我怎么知道这个外号?肯定是引起公愤了,有人贴出来的.

 x3y4z5 回复于:2002-11-12 22:14:15
mkfs -F -o inosize=1024,bsize=4096,ninode=0,largefiles /dev/vx/rdsk/datadg/vol01 
 
命令中的参数inosize=1024不能通过,选项中只有256,512两个选择。我实验了以下的命令
inosize=512,bsize=8192,ninode=0,version=4,largefile 但是结果都为sector must be positive and <=()1t.

 daemonix 回复于:2002-11-12 22:19:13
xyz345:
恭喜你啊,遇到贵人了,我怎么没有这么好的福气啊~~~~ :)

 phoenixli 回复于:2002-11-12 22:21:41
楼主你在干什么?不是说了不许贴的?好了,这个问题的回答到此为止.

 x3y4z5 回复于:2002-11-12 22:24:50
这个问题繁了我好几天,咨询了vetaris公司的人,他们也说怪。我都不知道是否我犯了低级错误?害得大家跟着忙乎。

 daemonix 回复于:2002-11-12 22:26:49
楼主,你惹得麻烦太大了,知道吗?
为什么要发这个帖子?哼?

 phoenixli 回复于:2002-11-12 22:27:07
解决是肯定可以解决的,但是,我现在不想回答了.

 x3y4z5 回复于:2002-11-12 22:35:57
使用我的邮件交流这样的技术问题真的台不爽了。如果不是几年以前我费掉了qq,现在道可以迅速获得帮助了。虽然phoenixli 不愿意继续关注这个问题,单我也要谢谢他的帮助。现在我只能等待别人的帮助了。chinaunix中的solaris是我见过的少有的灌水不多的论坛。希望各位对关注技术问题。珍惜这块洁净的技术绿地。谢谢了。

 johnyou 回复于:2002-11-12 22:37:25
The unit of allocation in VxFS is a block. Unlike some other UNIX file systems, VxFS does
not make use of block fragments for allocation because storage is allocated in extents that
consist of one or more blocks.
You specify the block size when creating a file system by using the mkfs –o bsize
option. The block size cannot be altered after the file system is created. The smallest
available block size for VxFS is 1K, which is also the default block size.
Choose a block size based on the type of application being run. For example, if there are
many small files, a 1K block size may save space. For large file systems, with relatively
few files, a larger block size is more appropriate. Larger block sizes use less disk space in
file system overhead, but consume more space for files that are not a multiple of the block
size. The easiest way to judge which block sizes provide the greatest system efficiency is to
try representative system loads against various sizes and pick the fastest. For most
applications, it is best to use the default values.
For 64-bit kernels, which support 32 terabyte file systems, the block size determines the
maximum size of the file system you can create. File systems up to 4 TB require a 1K block
size. For four to eight terabyte file systems, the block size is 2K, For file systems between 8
and 16 TB, block size is 4K, and for greater than 16 TB, the block size is 8K. If you specify
the file system size when creating a file system, the block size defaults to these values

能告诉你的IP吗?

 phoenixli 回复于:2002-11-12 22:42:54
算了,楼主,你要是想的话按照我刚才说的让我的技术替你解答?我可以告诉你,这个论坛里有95%的人都比不上我的技术,就别说什么刚接触了一年的SOLARIS丢了工作只怕都找不到.的半瓶水了,
SORRY,又动火了,看来还是脾气不好.
如果你愿意我把你的E-MAIL给他.

 x3y4z5 回复于:2002-11-12 22:44:55
bsize选项使用默认的我也实验过了。不行

 phoenixli 回复于:2002-11-12 22:46:18
你真的要告诉他吗?

 x3y4z5 回复于:2002-11-12 22:50:11
why not?

 phoenixli 回复于:2002-11-12 22:51:58
楼主,不是跟你讲,继续你的问题吧,算你好运.

 x3y4z5 回复于:2002-11-12 23:10:10
今天该回了,郁闷。5。。。。。。。。。。

 x3y4z5 回复于:2002-11-13 11:33:26
今天仔细察看了保错信息,发现,如果我mkfs时候给出文件系统的大小,可以完成。到了mount的时候,系统报错信息为layout is not supported on this version of vxvm.难道是我用的vxvm 3.1.1不支持超过1t的文件系统?我正在查找相关的文档,那位老大有印象指点一下。目前我没有查找道。

 YT 回复于:2002-11-13 11:47:49
SUN方面暂时好像没有这种BUG Report。
试试vxvm 3.2呢?

 x3y4z5 回复于:2002-11-13 11:56:21
手头没有。如果能查找道3.1.1不支持的依据,就可以申请升级3.1.1到3.2的版本了。我在admin,release等文件中没有找到呀?

 YT 回复于:2002-11-13 12:11:22
phoenixli那里有的,你问他借,呵呵


 x3y4z5 回复于:2002-11-13 12:14:41
昨天已经得罪他了,据说他不再上来了?我怎么联系她/

 netbackup 回复于:2002-11-13 15:11:17
去61.150.43.138下载,我上传了。unix/unix2002

 x3y4z5 回复于:2002-11-13 15:48:43
找到了,正在下,谢谢诸位的帮助了。忙了好几天。我感觉这个问题是vxvm的版本3。1。1不支持超过1t的文件系统。等到我能确认后,回来总结一下。

 johnyou 回复于:2002-11-13 17:48:35
VXVM 3.1.1的软件限制中没有这一项说明。也许是你的做法有问题。vxprint -ht贴来看看。

 x3y4z5 回复于:2002-11-13 21:24:03
Disk group: rootdg

DG NAME         NCONFIG      NLOG     MINORS   GROUP-ID
DM NAME         DEVICE       TYPE     PRIVLEN  PUBLEN   STATE
RV NAME         RLINK_CNT    KSTATE   STATE    PRIMARY  DATAVOLS  SRL
RL NAME         RVG          KSTATE   STATE    REM_HOST REM_DG    REM_RLNK
V  NAME         RVG          KSTATE   STATE    LENGTH   READPOL   PREFPLEX UTYPE
PL NAME         VOLUME       KSTATE   STATE    LENGTH   LAYOUT    NCOL/WID MODE
SD NAME         PLEX         DISK     DISKOFFS LENGTH   [COL/]OFF DEVICE   MODE
SV NAME         PLEX         VOLNAME  NVOLLAYR LENGTH   [COL/]OFF AM/NM    MODE

dg rootdg       default      default  0        1033262523.1025.LTdb

dm c0t0d0s6     c0t0d0s6     simple   1024     102639   -

Disk group: datadg

DG NAME         NCONFIG      NLOG     MINORS   GROUP-ID
DM NAME         DEVICE       TYPE     PRIVLEN  PUBLEN   STATE
RV NAME         RLINK_CNT    KSTATE   STATE    PRIMARY  DATAVOLS  SRL
RL NAME         RVG          KSTATE   STATE    REM_HOST REM_DG    REM_RLNK
V  NAME         RVG          KSTATE   STATE    LENGTH   READPOL   PREFPLEX UTYPE
PL NAME         VOLUME       KSTATE   STATE    LENGTH   LAYOUT    NCOL/WID MODE
SD NAME         PLEX         DISK     DISKOFFS LENGTH   [COL/]OFF DEVICE   MODE
SV NAME         PLEX         VOLNAME  NVOLLAYR LENGTH   [COL/]OFF AM/NM    MODE

dg datadg       default      default  100000   1033263634.1049.LTdb

dm datadg01     c1t2d0s2     sliced   36863    1286553600 -
dm datadg02     c1t2d1s2     sliced   36863    1286553600 -
dm datadg03     c1t3d0s2     sliced   36863    1286553600 -
dm datadg04     c1t3d1s2     sliced   36863    1286553600 -

v  vol01        -            ENABLED  ACTIVE   2566914048 SELECT  vol01-04 fsgen
pl vol01-04     vol01        ENABLED  ACTIVE   2566914048 STRIPE  2/128    RW
sv vol01-S01    vol01-04     vol01-L01 1       1283457024 0/0     3/3      ENA
sv vol01-S02    vol01-04     vol01-L02 1       1283457024 1/0     3/3      ENA

v  vol01-L01    -            ENABLED  ACTIVE   1283457024 SELECT  -        fsgen
pl vol01-P01    vol01-L01    ENABLED  ACTIVE   LOGONLY  CONCAT    -        RW
sd datadg01-06  vol01-P01    datadg01 0        2112     LOG       c1t2d0   ENA
pl vol01-P02    vol01-L01    ENABLED  ACTIVE   1283457024 CONCAT  -        RW
sd datadg01-09  vol01-P02    datadg01 36864    1048576000 0       c1t2d0   ENA
sd datadg01-10  vol01-P02    datadg01 1048633344 104857600 1048576000 c1t2d0 ENA
sd datadg01-14  vol01-P02    datadg01 1153511424 104857600 1153433600 c1t2d0 ENA
sd datadg01-15  vol01-P02    datadg01 1258389504 25165824 1258291200 c1t2d0 ENA
pl vol01-P03    vol01-L01    ENABLED  ACTIVE   1283457024 CONCAT  -        RW
sd datadg03-05  vol01-P03    datadg03 0        1048576000 0       c1t3d0   ENA
sd datadg03-09  vol01-P03    datadg03 1048596480 104857600 1048576000 c1t3d0 ENA
sd datadg03-10  vol01-P03    datadg03 1153474560 104857600 1153433600 c1t3d0 ENA
sd datadg03-11  vol01-P03    datadg03 1258352640 25165824 1258291200 c1t3d0 ENA

v  vol01-L02    -            ENABLED  ACTIVE   1283457024 SELECT  -        fsgen
pl vol01-P04    vol01-L02    ENABLED  ACTIVE   LOGONLY  CONCAT    -        RW
sd datadg01-16  vol01-P04    datadg01 2112     2112     LOG       c1t2d0   ENA
pl vol01-P05    vol01-L02    ENABLED  ACTIVE   1283457024 CONCAT  -        RW
sd datadg02-05  vol01-P05    datadg02 0        1048576000 0       c1t2d1   ENA
sd datadg02-09  vol01-P05    datadg02 1048596480 104857600 1048576000 c1t2d1 ENA
sd datadg02-10  vol01-P05    datadg02 1153474560 104857600 1153433600 c1t2d1 ENA
sd datadg02-11  vol01-P05    datadg02 1258352640 25165824 1258291200 c1t2d1 ENA
pl vol01-P06    vol01-L02    ENABLED  ACTIVE   1283457024 CONCAT  -        RW
sd datadg04-05  vol01-P06    datadg04 0        1048576000 0       c1t3d1   ENA
sd datadg04-09  vol01-P06    datadg04 1048596480 104857600 1048576000 c1t3d1 ENA
sd datadg04-10  vol01-P06    datadg04 1153474560 104857600 1153433600 c1t3d1 ENA
sd datadg04-11  vol01-P06    datadg04 1258352640 25165824 1258291200 c1t3d1 ENA
诸位看看有没有问题?

 phoenixli 回复于:2002-11-15 19:35:31
MMMN说不用我的技术来回答这个问题了,可是,怎么MMMN说的这个论坛里的高手也都不来回答呢?

 mmmmn 回复于:2002-11-15 19:38:56
别给我造谣,我是说你不要用命令的方式让他们来解答,如果他们自己愿意来,欢迎。
我不想因为这个给你的工程师添麻烦

 phoenixli 回复于:2002-11-15 19:41:26
奇怪了,你又没有付薪水给他们,他们为什么要一定回答这个问题?当然他们自己是不愿意的,只有我可以让他们来,因为我是付薪水的啊,你说想添麻烦,言外之意就是不要他们来了.
还有,我真的奇怪那些高手都哪里去了啊.

 mmmmn 回复于:2002-11-15 19:43:37
高手都忙,只有我们这样的才闲的来灌水:)
不来就不来啊,怎么?来这里的人都是自愿的

 phoenixli 回复于:2002-11-15 19:45:15
没怎么,我只要看到解决问题就好.

 YT 回复于:2002-11-15 19:48:52
都在向mmmmn学习,灌水呢。

 phoenixli 回复于:2002-11-16 23:29:52
楼主,你的问题解决没有,怎么没有结果了啊?

 YT 回复于:2002-11-17 01:19:46
一定是解决了  ;P

 johnyou 回复于:2002-11-17 11:26:57
Please Install your system with flowwing:
1  Install Your Solaris 8 (Version 02/02), At Least Solaris 8 (Update 2);
2  Install newest Recommend Patch(sunsolve.sun.com), This Patch include Vxfs need patch (108528-14 108987-09, 111293-04, 111310-01, 111111-03, and 112396-02 108901-04);
3  Install VXVM and License. Creat DG, Vol etc. 
4  Install VXFS and License. Creat File System. 
5  Tell me result. Ok! 


 x3y4z5 回复于:2002-11-17 16:53:36
周一按照你的步骤我做,有了结果公布出来。

 hnpygqs 回复于:2002-11-17 19:15:34
一群高手。等着看下文!!!

 YT 回复于:2002-11-17 19:25:37
太好了 ,恭喜恭喜!
作好了别忘记 还要投诉VERITAS的技术支持哦!

呵呵  ^_^

 windowsnt 回复于:2002-11-17 22:22:12
不是还没有结果吗?恭喜什么?

 phoenixli 回复于:2002-11-17 23:29:51
人家可以看见结果啊,这就是高人和普通人的区别

 windowsnt 回复于:2002-11-18 08:52:06
pfpf

 YT 回复于:2002-11-18 11:59:46
[quote][b]下面引用由[u]phoenixli[/u]在 [i]2002/11/17 11:29pm[/i] 发表的内容:[/b]
人家可以看见结果啊,这就是高人和普通人的区别
[/quote]

倒,有这么变着法儿的说自己的SE好的嘛?  

 x3y4z5 回复于:2002-11-18 15:42:02
我下载了补丁,安装后重启机器还是不行。我的操作系统02/02版本,打了推荐的补丁。我根据johnyou提供的补丁由下载了系统中没有的两个补丁。结果还是不行。

 johnyou 回复于:2002-11-18 15:45:11
错误还一样吗?按我说的方法,有人做个4T的。就不是我自己做的了。错误贴上看看。

 x3y4z5 回复于:2002-11-18 15:56:48
[quote][b]下面引用由[u]johnyou[/u]在 [i]2002/11/18 03:45pm[/i] 发表的内容:[/b]
错误还一样吗?按我说的方法,有人做个4T的。就不是我自己做的了。错误贴上看看。
[/quote]
johnyou老大,我操作的报错还是this layout is not supported by version of vxvm.
操作步骤为mount -F vxfs /dev/vx/dsk/datadg/vol01 /u01
不知道作成功的卷中使用的vxvm是3。1。1版本否?文件系统vxfs3。5版本?

 YT 回复于:2002-11-18 21:29:50
faint
你先换个vxvm 3.2的试试,
要是还8行,你换vxfs 3.4版本算了。
要是还8行,带着小弟去SUN公司踢馆子!!!

 x3y4z5 回复于:2002-11-19 21:48:21
诸位老大:今天问题解决了,特来报告大家。供应商拿了一个volume manager3。5的盘过来,安装了之后,一切顺利解决。我当初的猜测终于得到了验证:3.1.1volume manager应该不支持超过1t的文件系统。这里的1t为1024g.如果那位老大使用volume manager3。1。1做过支持超过1t容量的文件系统麻烦在论坛李公布,告诉我纠正这个错误的结论。

原文转自:http://www.ltesting.net