| gadfly 回复于:2003-05-25 08:50:24 |
| 试试http配置改成
<IfModule mod_php4.c> AddType application/x-httpd-php .php4 .php3 .phtml .php AddType application/x-httpd-php-source .phps </IfModule> |
| haohaoo 回复于:2003-05-25 10:11:15 |
| 看你好像就是想实现
http://bbs.uc88.com/dataadmin/ 这样的效果吧,只要把phpmyadmin里面的config.inc.php修改一下就行了啊,把$cfg['Servers'][$i]['auth_type'] = 'config'中config修改为http就行了 |
| ours 回复于:2003-05-25 11:06:18 |
| auth类型已经在config.inc.php文件中改过了,还是显示页面源码啊
到底是怎么回事呢? 而从其它机子访问此目录, http://192.168.1.151/myadmin 则显示页面,可是后面却有个“404 Not Found error ” 页面显示内容如下: Authorization Required This server could not verify that you are authorized to access the document requested. Either you supplied the wrong credentials (e.g., bad password), or your browser doesn't understand how to supply the credentials required. Additionally, a 404 Not Found error was encountered while trying to use an ErrorDocument to handle the request. |
| ours 回复于:2003-05-25 13:37:12 |
| 我又修改了httpd.conf中的内容
把/error/的别名那一行注释去掉了 又把.htaccess文件的内容如下更改: AuthUserFile /usr/local/apache/pass/pwdPhp AuthType Basic AuthName "Database Security Zone" #ErrorDocument 401 /catchErrors/err_401.html ErrorDocument 401 /error/HTTP_UNAUTHORIZED.html.var require valid-user 重启apache后可以弹出输入密码的窗口 可是每次输入三次密码后就会连到出错信息页面 这是怎么回事呢? 我是用命令: ./htpasswd -bc /usr/local/apache/pass/pwdPhp admin ours 生成的密码文件,应该不会搞错吧? |
| 大麻 回复于:2003-05-25 13:40:42 |
| 为什么不用phpMyadmin 自己的认证? |
| blueriver 回复于:2003-05-25 13:59:53 |
| haohaoo说`的对
config修改为http就行了 我就能阿, 另外 我的phpmyadmin能正常连接,删除库,表,但 页面下总有这样的 错误 使用链接表的额外特性尚未激活。要查出原因,请单击此处。 单击进去了 有提示 PMA Database ... 不好[ 文档 ] 一般关系特性 已禁用 不知道为何? |
| haohaoo 回复于:2003-05-25 15:29:58 |
| [quote:be00388fb9="ours"]auth类型已经在config.inc.php文件中改过了,还是显示页面源码啊
到底是怎么回事呢? 而从其它机子访问此目录, http://192.168.1.151/myadmin 则显示页面,可是后面却有个“404 Not Found error ” 页面显示内..........[/quote:be00388fb9] 你别的php程序会不会出错,先看看你的php配好了没? |
| haohaoo 回复于:2003-05-25 15:32:29 |
| [quote:f85640a673="blueriver"]
一般关系特性 已禁用 不知道为何?[/quote:f85640a673] 是不是在最下面出现$cfg['PmaAbsoluteUri']错误,而且是红色的 你只要修改config.inc.php中$cfg['PmaAbsoluteUri']的值为你phpmyadmin的url路径就可以了,如:http://domain.com/phpmyadmin |
| ours 回复于:2003-05-26 12:13:28 |
| 谢谢!已经解决
的确是只需改动config.inc.php上的两个地方就好了 |
| bqcs 回复于:2004-01-28 11:28:43 |
| [quote:b739d5140d="haohaoo"]pe'] = 'config'中config修改为http就行了[/quote:b739d5140d]
请问,修改后登陆的用户名和密码应该在什么地方修改? |
| dcat1 回复于:2004-04-13 08:22:57 |
| 您配置文件中的设定与 MySQL 默认权限账户对应(没有密码的 root)。您的 MySQL 服务器使用默认值运行当然没有问题,不过这样的话,被入侵的可能性会很大,您真的应该先补上这个安全漏洞。 |
| dcat1 回复于:2004-04-13 08:45:48 |
| 我按照各位的方法我修改了
$cfg['PmaAbsoluteUri'] = 'http://192.168.0.11/php/'; 为什么错误依旧? 错误 使用链接表的额外特性尚未激活。要查出原因,请单击此处。 PMA Database ... 不好[ 文档 ] 一般关系特性 已禁用 |
| wlx 回复于:2004-04-21 14:44:20 |
| 错误
使用链接表的额外特性尚未激活。要查出原因,请单击此处。 PMA Database ... 不好[ 文档 ] 一般关系特性 已禁用 这是因为phpmyadin加了新功能。解决办法是 一,新建一个名字为phpmyadin的数据库 二。在phpmyadin中建数据表,可以直接从phpmyadin的scripts文件夹中导入sql文件,文件名字为create_tables.sql。 三,配置 config.inc.php 事实上也就是把你建立的表名称填到对应的位置。 其实在cofnig.inc.php后面就有缺省的键值,填上去就可以了,当然你也可以通过create_table.sql文件来写。只不过后面这个要麻烦些。 |