qmail+mysql+vpopmail+igenus的安装文档。

发表于:2007-06-08来源:作者:点击数: 标签:
在这里,我重点讲的是igenus的安装和调试,qmail的安装不再详细说明了。 我的系统环境: 系统:redhat7.2 环境:qmail+my sql +vpopmail+qmailadmin 在安装之前,你要必须满足一下条件。 1、安装apache+php 2、安装qmail+mysql+vpopmail成功。 3、下载igenus_

在这里,我重点讲的是igenus的安装和调试,qmail的安装不再详细说明了。
我的系统环境:
系统: redhat 7.2
环境:  qmail+mysql+vpopmail+qmailadmin
在安装之前,你要必须满足一下条件。
1、安装apache+php
2、安装qmail+mysql+vpopmail成功。
3、下载igenus_2_20030311.tgz (www.igenus.org)

首先,安装apache+php。我没有系统默认安装apache和php,因为要手工配置一下。
1、下载httpd-2.0.40.tar.gz (www.apache.org)
       php4-200303121030.tar.gz (http://snaps.php.net)
 #  mkdir /home/software   ---把需要的文件放在software目录中。
2、安装apache
 # cd /home/software/
 # tar -zxvf httpd-2.0.40.tar.gz
 # cd httpd-2.0.40
 # ./configure --prefix=/var/www --enable-modules=so
 # make 
 # make install
 # vi /var/www/conf/httpd.conf
   添加以下内容:

  AddType application/x-tar.tgz
  Addtype application/x-httpd-php .php
  LoadModule php4_module /var/www/modules/libphp4.so
  
  修改以下部分为:
  
  DirectoryIndex  index.php
  DocumentRoot "/var/www/igenus"
  <Directory   "/var/www/igenus">
  User vpopmail
  Group vchkpw

  #vi /etc/rc.d/rc.local
   添加:
   /var/www/bin/apachectl start
   注:使它开机自动启动。
     
 3、安装php
 # cd ../
 # tar -zxvf php4-200303121030.tar.gz
 # cd php4-200303121030
 # ./configure --with-mysql --with-apxs2=/var/www/bin/apxs
 # make
 # make install
 # cp php.ini-dist /usr/local/lib/php.ini
 # vi /usr/local/lib/php.ini
   register_globals =off  更改为:register_globals =on

  (注:我编译APACHE,是使它支持DSO模块。然后编译PHP,将SO文件安装到你的APACHE的模块目录里,这样也方便以后扩展功能.)

   接着,安装qmail+vpopmail+mysql+(qmailadmin可选)。在这里,就不详细的讲解它的安装了,大家可以参考其他的文献。对于初级用户,建议适用iceblood编写的qmail_setup-v1.5.3.tar.gz 或者
qmail_setup-v1.5.4a.stable.tar.gz,也是不错的。网上很多地方可以下载,也可以在论坛上和iceblood联系啊。如果用qmail_setup安装包的版本,解包后详细阅读install和setup文件,根据需要修改setup。
   当安装完qmail+mysql+vpopmail时,要修改以下mysql的库文件的vpopmail databases。

# mysql -uroot -ppassword   password---你的密码

在mysql中创建address表,具体表结构如下:
# use vpopmail
# create table address 

id int(11) unsigned NOT NULL auto_increment, 
pw_id int(5) unsigned NOT NULL default '0', 
name varchar(64) NOT NULL default '', 
email varchar(12 NOT NULL default '', 
UNIQUE KEY id (id), 
KEY pw_id (pw_id) 
);
修改原来的vpopmail表,方法如下:
use vpopmail; 
alter table vpopmail drop primary key; 
alter table vpopmail add column pw_id int(5) NOT NULL primary key auto_increment;

(注:添加address table,是因为要使用igenus中的个人通讯录,添加pw_id是因为igenus用它来标识用

户的唯一性的,但vpopmail用的是pw_uid)

最后,安装igenus.
1、安装igenus
 # cd /home/software
 # cp igenus_2_20030311.tgz /var/www
 # cd /var/www
 # mkdir temp
 # chown vpopmail.vchkpw temp
 # tar zxvf igenus_2_20030311.tgz

 2、修改config/config_inc.conf文件。config_inc.conf是iGNEUS的配置文件,必须正确设置,具体设

置如下:
 # vi /var/www/igenus  

$CFG_BASEPATH = "/var/www/igenus";
$ CFG_BASEPATH -----是iGNEUS webmail安装在系统的路径。

$CFG_MYSQL_HOST = 'localhost';
$CFG_MYSQL_HOST -----是mysql服务器的地址。

$CFG_MYSQL_USER = 'root';
$CFG_MYSQL_USER -----是mysql服务器的用户名。

$CFG_MYSQL_PASS = '123456';
$CFG_MYSQL_PASS -----是mysql服务器的密码,根据你的实际填写

$CFG_HOSTNAME = "http://bsd.gic.ac.cn/mail/"; 
$CFG_HOSTNAME-----是服务器的主机名,根据你的实际填写

$CFG_LANGUAGE = gb; 
$CFG_LANGUAGE-----是系统默认语言,可有中英日可选。

$CFG_GMT = +8;                  // GMT time local
$CFG_GMT----是时区设置,中国选+8。

$CFG_TEMP = $CFG_BASEPATH."/../temp";
$CFG_TEMP----临时文件的位置。

3、修改默认登录域的设置,编辑login.php,查找以下字符,可设置你默认的邮件主机地址,可以设置多个。当然了,不改也可以的,略过这一步。

# vi /var/www/igenus/login.php

<INPUT CLASS=myinput2 TYPE="text" NAME="name" VALUE="news" 
SIZE="10" STYLE="font-family: Tahoma">
         @
        <INPUT TYEP="test" NAME="domain" VALUE="<?php echo $ Cookies_Domain;?>" SIZE="19" CLASS="myinput2" STYLE='font-family:Tahoma'>  ----删除@后面的句子,改变成以下:

         <option value="webmail.readchina.com:>webmail.readchina.com</option>                                           

好了,到这里,就全部结束了。
测试一下:
# /var/www/bin/apachectl start
# /home/vpopmail/bin/vadddomain mydomains.com  --添加域
# /home/vpopmail/bin/vadduser [email protected] --添加用户
你要是安装了qmailadmin,也可以从web添加用户。
浏览: httpd://domydomains.com ,就可以看到你的mail了。

后续:
      今天太累了,看了一天的显示器,眼睛都快瞎了。就先写到这吧,有时间,我再把qmail+mysql+vpopmail的安装写一些。igenus可能在使用中还有一些需要根据你的实际情况要设置的,我会不断的补充上来的。由于写的匆忙,有什么问题,欢迎和大家讨论。在这里,也感谢论坛网友rocklzy的无私帮助。

 wolf1980 回复于:2003-03-25 21:30:45
peng:
您太棒了。
我马上试一试

谢谢!!!!!!!!!!

自由世界就是么好!!!!!!!!!!

没办法!!!!!!!!!

好人太多!!!!!!!!!

 henkon 回复于:2003-03-26 00:46:50
如果iceblood能做一个全部的安装包就好的 呵呵

 白狐狸 回复于:2003-03-26 07:43:26
按照peng老大的做法,已经搞定igenus WEBMAIL,高兴啊,脱帽向peng老大致以崇高的敬意~~~~~

http://61.187.64.229/igenus/

[email protected]
passwd: test

不过peng老大的文档还有少许错误,大家可要看认真喽,呵呵

 peng 回复于:2003-03-26 09:52:39
to 白狐狸:
都有什么地发错啊?
赶快一一说明!
不然我可要放狗咬人了。:)

 Lanyd 回复于:2003-03-26 10:01:37
真NB!
原来做在线邮局就这么简单呀,谢谢!!!

 wmeng 回复于:2003-03-26 11:01:24
[quote:ec9093d43f="peng"]在这里,我重点讲的是igenus的安装和调试,qmail的安装不再详细说明了。
我的系统环境:
系统: redhat 7.2
环境:  qmail+mysql+vpopmail+qmailadmin
在安装之前,你要必须满足一下条件。
1、安装apache+php
2..........[/quote:ec9093d43f]

老兄的这篇文章很不错  
最近我也在看关于Qmail的设定,但是遇到了不少的问题。
能否大家一起讨论一下关于这方面,另外如何安全和优化呢?
谢谢

 bsdbase 回复于:2003-03-26 15:56:16
[quote:f0957362aa="peng"]在这里,我重点讲的是igenus的安装和调试,qmail的安装不再详细说明了。
我的系统环境:
系统: redhat 7.2
环境:  qmail+mysql+vpopmail+qmailadmin
在安装之前,你要必须满足一下条件。
1、安装apache+php
2..........[/quote:f0957362aa]

我,我,我 .......想要postfix下类似的实现~~ ops:  ops:

 peng 回复于:2003-03-26 16:42:13
to bsdbase:
应该是可以的,但要修改igenus的程序了。

 Deepocean168 回复于:2003-03-30 03:45:53
peng老大,我用8.0,apache和php已经整合好,mysql在装系统时也搞定,iceblood的包也按照说明档装了(没装httpd和sqwebmail),可是现在mysql和vpopmail好像关联不起来,mysql下面连vpopmail这个库都没有,怎么回事阿?
       谢谢!^_^

 神经到底 回复于:2003-03-31 06:32:49
本来我用qmail_setup安装的好好的了,看了peng的文章,我就开始了痛苦的探索……

首先我发现我用的_SQL=y选项根本不起作用,mysql里面根本就没有vpopmail这个数据库,我只好慢慢分析 setup script。

由于我的mysql版本是4.0.12max,我好像没看到哪里有 libmysqlclient.so.10 这个文件,因此在安装qmail_setup的时候,我把 'find $_LIBDIR -name libmysqlclient.so.10' 那一段检测去掉了,然后安装……可是不成功,vpopmail报告说“mysql server gone away... maybe gone with the wind”。

然后我不断乱试……包括单独编译每个包……还是没有成功

后来我终于我在安装包里面发现一个,就把它cp到/usr/lib里面,然后从新再安装……这回用vpopmail添加一个域,他说该域已存在,我要删掉那个域的时候,他又说该域不存在……真是很幽默!

结果我在计算机前面坐了一个通宵……

 Deepocean168 回复于:2003-03-31 22:11:51
我也是同样得问题呀,郁闷很久了,难道iceblood的包里关于mysql的那段脚本真的有问题?没有理由呀,我仔细看过,里面关于vpopmail的那段参数设定并没有没涉及到的方面呀!

 marinestat 回复于:2003-04-01 14:17:38
peng老大,好象是有错误啊。只能显示IGENUS。登陆显示如下错误:
Error create directory /var/www/igenus/var/www/temp,you must make /var/www/igenus/var/www/temp directory manual.Please read the INSTALL file.
Warning: Unknown(): Your script possibly relies on a session side-effect which existed until PHP 4.2.3. Please be advised that the session extension does not consider global variables as a source of data, unless register_globals is enabled. You can disable this functionality and this warning by setting session.bug_compat_42 or session.bug_compat_warn to off, respectively. in Unknown on line 0



求解

 marinestat 回复于:2003-04-01 14:42:16
急~~~~~~~~~~~~~~peng老大在吗?联系qq:1411472

 peng 回复于:2003-04-01 15:07:08
to  marinestat   :错误提示不是说得听清楚吗?
1、看看你的/var/www/temp 的权限,按照我的文档说得做了吗?
2、安装php时,有没有register_globals = on ?

to 神经到底:他说存在可能是在qmail的中设置了,qmail-setup我也没仔细看,但我用过,是可以用的。你最好都删除掉,重新安装。我也玉见过这种情况,我就是重新安装的,就没事了。

to Deepocean168:你的数据库更改用户和密码了吗?

 Deepocean168 回复于:2003-04-01 15:49:28
多谢大麻!
      问题已经搞定了,原来是vpopmail中mysql的root用户的密码跟mysql
本身root用户的密码不相同,我把iceblood包中的vpopmail解压看过了,里面的密码是secret,我想这里面不好改,于是就到mysql中改root的密码为secret,并且把安装包里mysql的root用户密码也该成了secret(不知道有用没有),编译setup包后mysql当中仍然没有自动生成vpopmail库,于是manual之,并按照大麻的提示在vpopmail库中创建address表,再去/home/vpopmail/bin下添加域名跟用户,ok!mysql的vpopmail库vpopmail表中果然自动添加了域名跟用户!搞定!!!
       真是感谢大麻,让我走出了一周来的阴影........
        3xing.............

 marinestat 回复于:2003-04-01 15:51:41
谢谢PENG。解决了。

 leaper 回复于:2003-04-01 23:57:18
好像不行,PHP+HTTPD     编译时通不过,!!!

 marinestat 回复于:2003-04-02 11:04:39
为什么只能收不能发啊。郁闷

 firer2000 回复于:2003-04-10 08:38:54
我在安装完成后用igenus登陆时总是无法通过身份验证!!这是什么原因。我看到自己建立的用户已经在vpopmail的表里面

 kelei 回复于:2003-04-18 01:55:18
[quote:53f7ab7d72="firer2000"]我在安装完成后用igenus登陆时总是无法通过身份验证!!这是什么原因。我看到自己建立的用户已经在vpopmail的表里面[/quote:53f7ab7d72]

我也有同样问题,

在login.php中session_unset()后$domain被冲空,问题出在这里

但是我不懂php,不知道如何解决

哪位高手来援手?

 haohaoo 回复于:2003-04-20 16:44:18
安装完qmail后,mysql中没有vpopmail这个库

 lihn 回复于:2003-04-21 08:38:26
[quote:5ee82bc26a="白狐狸"]按照peng老大的做法,已经搞定igenus WEBMAIL,高兴啊,脱帽向peng老大致以崇高的敬意~~~~~

http://61.187.64.229/igenus/

[email protected]
passwd: test

不过peng老大的文档还有少许错误,大家可要看认真?.........[/quote:5ee82bc26a]
我在你的系统上注册了一个帐号但出错了:
vmysql: sql error[3]: Table 'vpopmail.vpopmail' doesn't exist

 xiaotuhzb 回复于:2003-04-24 16:55:53
[quote:f759clearcase/" target="_blank" >cca0eb="Deepocean168"]我也是同样得问题呀,郁闷很久了,难道iceblood的包里关于mysql的那段脚本真的有问题?没有理由呀,我仔细看过,里面关于vpopmail的那段参数设定并没有没涉及到的方面呀![/quote:f759cca0eb]

我也遇到上面同样的问题!

 白狐狸 回复于:2003-04-25 08:46:55
[quote:24378ef5b9="lihn"]e 'vpopmail.vpopmail' doesn't exist[/quote:24378ef5b9]

前些日子系统维护中,偶把邮件系统给重做了,呵呵

 ncwangw 回复于:2003-04-25 20:19:51
白狐狸大侠,您好!
我下载的vqsignup只有用户名和密码功能,而您的还有输入真实姓名的功能,您能把修改过的vqsignup 给我一份吗?谢谢了    [email protected]
          

 babodx 回复于:2003-04-30 03:01:55
我一登陆就出现如下错误
Warning: session_start() [function.session-start]: open(/tmp/sess_57574f710f602d4241c1581d07a59088, O_RDWR) failed: Permission denied (13) in /usr/local/apache/htdocs/igenus/login.php on line 37

Warning: session_start() [function.session-start]: Cannot send session cache limiter - headers already sent (output started at /usr/local/apache/htdocs/igenus/login.php:37) in /usr/local/apache/htdocs/igenus/login.php on line 37

 garfy 回复于:2003-04-30 08:42:03
仔细看看login.php中该行怎么写的,是否和你的mysql一致。

 haohaoo 回复于:2003-04-30 17:51:19
不知道peng老大那个注册的怎么做?
有没有忘记密码那项?

 zengpx 回复于:2003-05-04 22:37:17
peng老大:

  请推荐几篇有关安装qmail+mysql+vpopmail的文章给我,好吗?

 peng 回复于:2003-05-04 23:24:34
[quote:c4172e6036="zengpx"]peng老大:

  请推荐几篇有关安装qmail+mysql+vpopmail的文章给我,好吗?[/quote:c4172e6036]
正在点灯熬夜的写。:)

 tony_list 回复于:2003-05-05 15:15:13
[quote:3f823b540e="Deepocean168"]我也是同样得问题呀,郁闷很久了,难道iceblood的包里关于mysql的那段脚本真的有问题?没有理由呀,我仔细看过,里面关于vpopmail的那段参数设定并没有没涉及到的方面呀![/quote:3f823b540e]

 笨笨鸟 回复于:2003-05-05 16:40:52
[quote:a03605c484="神经到底"]本来我用qmail_setup安装的好好的了,看了peng的文章,我就开始了痛苦的探索……

首先我发现我用的_SQL=y选项根本不起作用,mysql里面根本就没有vpopmail这个数据库,我只好慢慢分析 setup script。

由于我的m..........[/quote:a03605c484]
确实有问题,你可以找到libmysqlclient.a,你只要把它复制一份,将文件名改为libmysqlclient.so.10。就可以了!

 zengpx 回复于:2003-05-05 22:43:38
在此先感谢peng老大啦!

 lcycc1 回复于:2003-05-06 08:57:17
[quote="peng"]
#vi/var/www/igenus/login.php 

<INPUTCLASS=myinput2TYPE="text"NAME="name"VALUE="news"
SIZE="10"STYLE="font-family:Tahoma"> 
@ 
<INPUTTYEP="test"NAME="domain"[color=red:27748a673f]VALUE[/color:27748a673f]="<?phpecho$Cookies_Domain;?>"SIZE="19"CLASS="myinput2"STYLE='font-family:Tahoma'>----删除@后面的句子,改变成以下: 

optionvalue="webmail.readchina.com:>webmail.readchina.com</option>quote]
大家如果只有一个域名话就不用在@删除什么了,在红色VALUER里,删除php什么的,后面加上一你的域名,就可以像mail.szfocus.net 一样了

 lcycc1 回复于:2003-05-06 09:05:06
还在大家如果用的是apache2.0.45+php_4.3.0
+mysql_4.0.10时(当然我是用的)
安装好了igenus后,打开时发出现在一些warning
这时你不想看到warnig,你可把/usr/local/lib/php.ini
里的display_errors=On改成Off
再按照peng兄做,应该是没有问题的

 binzai 回复于:2003-05-08 16:10:22
有谁在FreeBSD中安装成功过的?

 garfy 回复于:2003-05-08 17:37:41
不用iceblood的,自己安装在FreeBSD上没问题。

 test_tmp 回复于:2003-05-10 18:17:55
虽然,我还没有试,但你写得太棒了,谢谢你提供这么好的文章!

 garfy 回复于:2003-05-11 11:35:50
peng老大的这篇东西的确不错,比大麻兄的说明还对我胃口

 test_tmp 回复于:2003-05-11 11:37:59
请问一下,igenus在哪里下载呀!我是不是很笨!

 test_tmp 回复于:2003-05-11 13:17:16
请教大家,我照着peng的文章做了,用英文是可以了,但是,如果换成中文后,进去后,出来的都是乱码,但是用查源文件来看的话,在客户端的源文件里的是正常的!我实在不明白,请大家指点,我的linux到是没有装中文!

 风婉儿 回复于:2003-05-11 20:53:12
[quote:775b09b4d3="test_tmp"]请教大家,我照着peng的文章做了,用英文是可以了,但是,如果换成中文后,进去后,出来的都是乱码,但是用查源文件来看的话,在客户端的源文件里的是正常的!我实在不明白,请大家指点,我的linux到是没有装中文![/quote:775b09b4d3]

应该是apache的问题!你是不是用的httpd2.*?
vi httpd.conf文件。
AddDefaultCharset ISO-8859-1 改为 AddDefaultCharset off
就ok了
其实不是apache的问题,是微软ie的问题,不标准。

 ysb 回复于:2003-05-20 16:18:30
不想成为垃圾邮件的转发站!

 hss202 回复于:2003-06-12 10:22:11
我的装好了,可以发信的时候却出来这个

Fatal error: Call to undefined function: mail() in /opt/www/igenus/include/send_fun.php on line 529


帮忙看看!!!谢谢
!!!

 windblow 回复于:2003-06-16 08:19:04
我在用igenus登录后,出现错误提示不能进到邮箱界面,不知是什么原因,麻烦各位老大看看是什么原因呢?
   Fatal error: Call to undefined function: mysql_connect() in /var/www/html/igenus/login.php on line 42

 lzyking 回复于:2003-06-17 16:39:02
peng老大:我把一切都弄好了,用igenus发邮件也没问题,可是在发送附件的时候总是不能正常发送,这个问题该怎么解决呢?

 wingger 回复于:2003-07-24 08:39:54
我不是应该重新安装php?

 wingger 回复于:2003-07-24 08:37:26
错误:Fatal error: Call to undefined function: mysql_connect() in /var/www/html/igenus/login.php on line 42

    我的邮件系统组成(linux,radhat9.0,mysql4)qmail+mysql+vpopmail+cmd5checkpassword+qmailadmin+ezmlm
+autorespond.
   我的邮件系统收发正常,smtp验证也可以用,qmailadmin也正常,
但是igenus就是不能用。
   一登陆就出现上述错误

 czc9 回复于:2003-08-08 14:47:46
我的是出现如下问题
Warning: mysql_connect() [function.mysql-connect]: Access denied for user: 'root@dbsvr' (Using password: YES) in /var/www/igenus/login.php on line 42

Warning: mysql_select_db(): supplied argument is not a valid MySQL-Link resource in /var/www/igenus/login.php on line 43

 czc9 回复于:2003-08-08 21:12:39
经过重装系统,现在已经完全搞好了,上面的哪个问题也没有了。我现在也不知道是什么原因。太感谢PENG了

 yeeler 回复于:2003-08-12 00:56:29
我也遇到过,神经到底兄的问题,没有坐1晚,我重装了。上次安装被中断,结果,删么说不存在,./vdominfo 么 关于这个域的信息都在,郁闷坏了。
其实这些东东都在mysql的vpopmail库里。进入mysql,drop database vpopmail; 就ok了  呵呵。

 netocool 回复于:2003-09-24 22:16:20
[quote:7847541ece="windblow"]我在用igenus登录后,出现错误提示不能进到邮箱界面,不知是什么原因,麻烦各位老大看看是什么原因呢?
   Fatal error: Call to undefined function: mysql_connect() in /var/www/html/igenus/login.php on line 42[/quote:7847541ece]     

在第二张碟那里找到php-mysql-xxxxx
rpm -vih php-mysql-xxxxx
就OK拉

原文转自:http://www.ltesting.net