Request entity too large!错误!

发表于:2007-06-08来源:作者:点击数: 标签:
我用blog程序pmachine上传文件,稍微大一点(600k)就出现这个错误~~ 郁闷.... 小的没问题~ Requestentitytoolarge! ThePOSTmethoddoesnotallowthedatatransmitted,orthedatavolumeexceedsthecapacitylimit. Ifyouthinkthisisaservererror,pleasecontactthewebm

我用blog程序pmachine上传文件,稍微大一点(600k)就出现这个错误~~


郁闷....
小的没问题~

Request entity too large!
The POST method does not allow the data transmitted, or the data volume exceeds the capacity limit. 
If you think this is a server error, please contact the webmaster 
Error 413
haohan.bdcf.net 
2004年08月07日 星期六 15时52分24秒 
Apache/2.0.40 (Red Hat Linux)

 deadcat 回复于:2004-08-07 16:39:46
找了半天~~居然在[url=http://www.phpbuilder.com/lists/php-install/2002111/0096.php]phpbuilder[/url]找到了解决方法




是因为php.conf文件~~不知道为什么在apache目录的conf.d文件夹中有个php.conf文件
把其中的
LimitRequestBody
值改大即可(my apache版本Apache/2.0.40 (Red Hat Linux 9.0)
下面附上phpBUilder原文
> OK, thanks for no help whatsoever. But I'm not bitter; I'm here 
> to 
> > report what I found so that the next guy with this problem isn't 
> stuck: 
> > 
> > The PHP docs say to change variables in /etc/php.ini (like the 
> whole 
> > world knows about) but the key is to *also* look into php.CONF, too. 
> > That's where the problem was
> > 
> > And though I don't understand why the second file was there, or 
> why no 
> > one piped up about it, this is the obscure answer to an obscure 
> problem. 

> You say you're not bitter, but it doesn't sound that way. 

> Remember, no one is getting paid to do this. Some questions just go 
> unanswered, sorry. All you can do is rephrase and ask again or ask 
> somewhere else. 

> But, thank you for posting the solution you did eventually find. That 
> will be of assistance if anyone ever searches the archives before 
> posting... 

> Hey, I can dream, can't I?? 

> ---John Holmes...

原文转自:http://www.ltesting.net