Sybase11.9.2 for unixware 安装
发表于:2007-06-08来源:作者:点击数:
标签:
Sybase11.9.2forunixware安装 1.1.环境检查 查看系统的硬件和软件环境是否满足sybase的安装要求,并用相应命令检测。 1.1.1.物理内存 内存大小:256M以上 检查命令: #prtconf 1.1.2.硬盘空间 系统的空闲磁盘空间必须大于6G。 检查命令: #df-k 1.1.3.操作系
Sybase11.9.2 for unixware 安装
1.1. 环境检查
查看系统的硬件和软件环境是否满足sybase的安装要求,并用相应命令检测。
1.1.1. 物理内存
内存大小:256M以上
检查命令:
#prtconf
1.1.2. 硬盘空间
系统的空闲磁盘空间必须大于6G。
检查命令:
#df -k
1.1.3. 操作系统
操作系统:unixware 7.1.1
查看操作系统版本号命令如下:
#uname –a
1.2. 安装介质
光盘一张:Adaptive Server Enterprise version11.9.2 For SCO unixware
1.3. 安装前的准备
1.3.1. 建立SYBASE用户
#scoadmin ---àa
clearcase/" target="_blank" >ccount manager----àuser-----àadd new user
用户目录为:/home/Sybase
默认shell为:ksh
1.3.2. 修改用户环境变量文件
修改SYBASE用户的shell文件,即SYBASE用户目录下的.profile文件,增加SYBASE,DSQUERY,PATH,LD_LIBRARY_PATH 环境变量
sh or ksh 中修改SYBASE用户的.profile文件,增加如下内容:
SYBASE = 安装目录(一般为SYBASE的用户目录。如:/home/sybase)
DSQUERY =
数据库服务器的名字(默认为SYBASE)
LD_LIBRARY_PATH=$SYBASE/lib.
PATH = $SYBASE/bin:$SYBASE/install:$PATH:.
export SYBASE DSQUERY PATH LD_LIBRARY_PATH
1.3.3. 系统参数调整
1、最大共享内存调整
编辑/etc/conf/cf.d/stune
加入:
SHMMAX 内存大小(字节)
SHMALL 2048
NPROC 500
ARG_MAX 51200
SFNOLIM 400
SFSZLIM 0x7FFFFFFF
HFSZLIM 0x7FFFFFFF
SDATLIM 0x7FFFFFFF
HDATLIM 0x7FFFFFFF
SCORLIM 0x7FFFFFFF
HCORLIM 0x7FFFFFFF
SVMMLIM 0x7FFFFFFF
HVMMLIM 0x7FFFFFFF
SSTKLIM 0x7FFFFFFF
HSTKLIM 0x7FFFFFFF
2、重建内核
# /etc/conf/bin/idbuild
3、重新启动计算机
# shutdown -y -g0 -i6
4、检查最大共享内存是否调整
#cd /etc/conf/cf.d
#more stune.current
检查stune.current文件中是否有“SHMMAX ‘内存’”存在,如果存在就证明修改内核成功。否则不成功。
1.3.4. 创建裸设备
因为要求数据库是建在裸设备上的,所以在安装数据库前要先创建裸设备。创建裸设备的具体步骤见《附件4.4:unixware裸设备的建立方法》文档。要创建的裸设备列表为:
名称 空间大小 说明
/home/Sybase/master 80M Sybase服务的系统数据库
/home/sybase/temp 40M Sybase服务的temp数据库
/home/Sybase/systemdb 200M Sybase服务的系统数据库
/home/sybase/systemprocs 200M Sybase服务的系统数据库
/home/Sybase/mbfe/wkdatadb 400M 当前数据库,存放数据
/home/Sybase/mbfe/wkindexdb 100M 当前数据库,存放索引
/home/Sybase/mbfe/wkdblog 200M 当前数据库,存放日志
/home/Sybase/mbfe/hisdatadb 3G 历史数据库,存放数据
/home/Sybase/mbfe/hisindexdb 300M 历史数据库,存放索引
/home/sybase/mbfe/hisdblog 400M 历史数据库,存放日志
1.4. 安装sybase
1.4.1. 安装11.92
#mount –F cdfs –r /dev/cdrom/cdrom1 /mnt
#su – sybase
$ /mnt/sybload –D
输入:Y (确认安装目录)
输入:L (本地安装)
输入:/mnt/sybimage
输入CAS# (34个字母,不区分大小写)(BKBYBK BKBKBY BFKZBK BKBYBY TMVOVG ZEBQ 
选择产品序号,“1”是必须要安装的。其他可以不选择。
(敲两次回车键结束)
Y (确认选择的产品)
安装结束后:进入root用户
#umount /mnt
1.4.2. 修改资源文件
$cd $SYBASE/init/sample_resource_files
$cp *ada* ase.rs
$cp *back* back.rs
编辑ase.rs 和back.rs
编辑后的ase.rs文件如下:
sybinit.release_directory: /home/sybase
sybinit.product: sqlsrv
sqlsrv.server_name: SYBASE
sqlsrv.new_config: yes
sqlsrv.do_add_server: no
sqlsrv.network_protocol_list: tli tcp
sqlsrv.network_hostname_list:168.33.56.173
sqlsrv.network_port_list: 5000
sqlsrv.master_device_physical_name:/home/sybase/master
sqlsrv.master_device_size:80
sqlsrv.master_database_size: 50
sqlsrv.errorlog: USE_DEFAULT
sqlsrv.do_upgrade: no
sqlsrv.sybsystemprocs_device_physical_name /home/sybase/systemprocs
sqlsrv.sybsystemprocs_device_size: 150
sqlsrv.sybsystemprocs_database_size: 150
sqlsrv.sybsystemdb_device_physical_name:/dev/rdsk/systemdb
sqlsrv.sybsystemdb_device_size: 40
sqlsrv.sybsystemdb_database_size: 40
sqlsrv.default_backup_server: SYB_BACKUP
编辑后的back.rs文件如下:
sybinit.release_directory: /home/sybase
sybinit.product: bsrv
bsrv.server_name:SYBASE_BACK
bsrv.do_add_backup_server: yes
bsrv.network_protocol_list: tli tcp
bsrv.network_hostname_list:168.33.56.173
bsrv.network_port_list:5500
bsrv.language: USE_DEFAULT
bsrv.character_set: USE_DEFAULT
bsrv.tape_config_file: USE_DEFAULT
bsrv.errorlog: USE_DEFAULT
1.4.3. 编辑interfaces文件
输入dscp命令:
$dscp
此时出现“>>”提示符,然后输入open命令:
>>open
>>add SYBASE (增加sybase服务名称)
>>tli tcp (协议)
>>168.33.56.173,5000 (输入ip地址和端口号)
一直回车直到出现“>>”提示符
>>exit (退出)
(这一步操作产生的interfaces应该是第5步操作自动产生的。如果在执行第5步时报错是找不到interfaces文件时,再做此操作)
1.4.4. 启动
SQL_SERVER及BACKUP_SERVER
$cd $SYBASE/bin
$sr
vbuildres –r $SYBASE/init/sample_resource_files/ase.rs
$srvbuildres –r $SYBASE/init/sample_resource_files/back.rs
注:#号为使用root 用户操作,$号为使用sybase用户操作。
此ip地址只是举个例子,安装时为机器的ip地址。
1.5. 数据库检查
1)检查ASE是否正常工作
$showserver
看是否有一个或者多个(多CPU)dataserver进程
$isql –Usa –P –Ssybase
>select @@version
>go
2) 检查BACKUP SERVER 是否正常工作
$showserver
看是否有backserver进程
3)试关闭ASE SERVER 和BACKUP SERVER
运行以下命令,ase 及backup server进程消失,日志文件中无ERROR
$isql –Usa –P –Ssybase
>shutdown SYB_BACKUP
>go
>shutdown
>go
$showserver
检查dataserver 以及 backserver进程消失
1.6. 系统数据库调整
确定sql server可用的最大内存
首先需要确定计算级系统的物理内存总和,然后减去操作系统所需内存,若此计算机并非专门用于sql server,则需减去其他应用所需的内存。例如需要减去分配给sql server运行在同一机器上的客户应用程序所使用的内存。另为需要减去分配给additional network memory配置参数的内存,剩余部分即为sql server可用内存的总数。通常配置为系统物理内存的60-70%。
设置sql server可使用的最大内存的命令如下:
sp_configure “total_memory”,value(以页为单位)
注意:如果total memory参数的配置值大于sql server可使用的最大内存, sql server将无法启动。
修改sybase内存配置sp_configure “total_memory”,value(以页为单位)
配置最大数据库设备数
系统默认的最大数据库设备数是10个,这个值不能满足实际需要,要增加此值,改为20。
Sp_configure “number of device”,20
设置用户连接数
系统默认的用户连接数是25个,可根据实际需要来设置此值。每个用户连接需要70KB内存。修改命令如下:
sp_configure “number of user connections”,value
修改以上内容后需要重新启动sybase数据库,修改的内容才能生效。
[img][/img]
| meteor06 回复于:2003-08-01 10:49:10
|
不错 ;)
|
| nnpl 回复于:2003-08-01 13:34:31
|
哪们大侠有sybase11.92 ?能共享吗?
|
| unixgood 回复于:2003-08-01 14:01:04
|
miaomu2008
你好!
你在你帖子中提到,
“因为要求数据库是建在裸设备上的,所以在安装数据库前要先创建裸设备。创建裸设备的具体步骤见《附件4.4:unixware裸设备的建立方法》文档。要创建的裸设备列表为: ”
请问,能够把你的《附件4.4:unixware裸设备的建立方法》文档共享一下吗?
谢谢!
|
| SARS1 回复于:2003-08-01 17:28:00
|
up
|
| lianyong 回复于:2003-08-02 17:43:04
|
顶,希望见到《附件4.4:unixware裸设备的建立方法》文档共享
|
| yanguo66 回复于:2003-08-03 08:58:00
|
up
|
| edit 回复于:2003-08-03 10:11:57
|
又一个做支付系统的 
|
| unix007 回复于:2003-08-03 10:35:53
|
其实,我觉得用光盘上的setup图形界面来安装更方便省事,不用编辑resource文件,直接在图形界面输入相关的设置就可以了。
|
| 愚人帝国 回复于:2003-08-03 19:06:20
|
OK!
|
| mafia 回复于:2003-08-05 09:22:02
|
谁把公司的资料泄露出去了?连那个备注也一样???
建立裸设备有一点麻烦~要计算一下~呵呵~
|
| ycguolin 回复于:2003-08-07 07:35:04
|
好。
但不知道这种安装方法是否也适用于SCO UNIX 505呢?
如果不适用的话,可否有sybase 11.9.2 在SCO UNIX 505的安装步骤?
|
| sxzyb 回复于:2003-08-07 10:37:44
|
据我的了解,
sco openserver上的SYBASE数据库版本只能到11.0.3
从UNIXWARE上的最低版本是11.9.2
在unixware上最裸设备的方法是比较繁的。要很小心。
先用
prtvtoc -f file /dev/dsk/c0b0t0d0s0 (此处是硬盘的设备名)
这个命令就把这个设备的分片信息写到file文件中了。下面编辑这个文件
vi file
此处必须要按照文件格式增加你想安装数据库要用到的分片(相当与OPENSERVER下的DIVVY),增加完后保存退出。用
edvtoc -f file /dev/dsk/c0b0t0d0s0
命令写回。
在/de/(r)dsk/目录下会有你自己增加的c0b0t0d0s*,把这些东西都改为要安装数据库的用户和组就可以。
|
| unixgood 回复于:2003-08-07 13:37:43
|
[quote:c09f4a406a="miaomu2008"][/quote:c09f4a406a]
真的是好!好!!!!!
|
| daniel_w 回复于:2003-08-07 15:06:09
|
up
|
| saintdragon 回复于:2003-08-07 15:43:07
|
好像是公司的内部文档哟
|
| daniel_w 回复于:2003-08-07 16:53:15
|
请大家支持一下:
我安装完了,到执行下面命令时出现以下提示,请帮助分析分析:
$ srvbuildres -r $SYBASE/init/sample_resource_files/ase.rs
dynamic linker : srvbuildres : error opening libct.so
Killed
up
|
| wyf555 回复于:2003-08-12 10:18:28
|
谢谢。
[email protected]
|
| yanguo66 回复于:2003-08-12 10:44:48
|
俺也要一份!
[color=red:1c81f67cd6][email protected][/color:1c81f67cd6]
|
| woodsli_007 回复于:2003-08-13 17:15:11
|
资料都很好,很有帮助
顶
|
| woodsli_007 回复于:2003-08-13 17:16:45
|
资料很好 ,很有帮助
顶 
|
| wolf2602 回复于:2003-08-14 15:55:06
|
[quote:c747d699d8="edit"]又一个做支付系统的 [/quote:c747d699d8]
haha cncc de ren hen li hai ya!
|
| wenzi2003 回复于:2003-08-25 11:59:58
|
miaomu2008楼主说的很不错也很明白的,可以按这个步骤做就可以了,但在vi .profile时,在这一句中“LD_LIBRARY_PATH=$SYBASE/lib. ”的末尾应该没有这一点吧,如果加上这一点,则出现daniel_w所说的错误了。。
在建裸设备时,除了sxzyb说的那样,还有mount等后续步骤的。。。
|
| saintdragon 回复于:2003-08-25 14:45:47
|
[quote:116e37bd5d="daniel_w"]请大家支持一下:
我安装完了,到执行下面命令时出现以下提示,请帮助分析分析:
$ srvbuildres -r $SYBASE/init/sample_resource_files/ase.rs
dynamic linker : srvbuildres : error opening libct.so
Killed
..........[/quote:116e37bd5d]
sybase用户的.profile文件的环境变量设置错误
|
| yujf 回复于:2003-08-26 16:24:47
|

|
| yujf 回复于:2003-08-26 16:27:06
|
是的,和我正在学的资料是一样的
|
| saintdragon 回复于:2003-08-26 16:27:49
|
这段时间作人行支付系统的人蛮多的嘛
|
| sageyu 回复于:2003-08-28 19:19:20
|
多谢,我正需要这个东东![b:6964568ca1][/b:6964568ca1]
|
| fengyu114 回复于:2003-10-08 18:17:07
|
不错的好东东,顶!!!
|
原文转自:http://www.ltesting.net