[原创]关于 sco unixware 中用户的删除后不能重建的解决方法

发表于:2007-06-08来源:作者:点击数: 标签:
不知道大家在SCO Unix Ware中是否有遇到曾创建了一个用户, (例:useruid=600) 然后把这个用户删除; 现在还需要这个用户,并且uid不变的情况呢? 这时候创建该用户系统会出现下面的提示信息: Unabletocreatenewuseraccount:user Generalfailurecreatingus

不知道大家在SCO UnixWare中是否有遇到曾创建了一个用户,
(例:user   uid=600)
然后把这个用户删除;
现在还需要这个用户,并且uid 不变的情况呢?
这时候创建该用户系统会出现下面的提示信息:
Unable to create new user aclearcase/" target="_blank" >ccount: user 
General failure creating user account 
General failure occured in processing the request. 
Can't execute /sbin/tfadmin:UX:useradd:ERROR:uid 600 not aged sufficiently.Choose another. 
提示该uid 不能使用,要求你更换uid;

产生原因:
SCO UnixWare 系统的用户管理机制中默认为用户 uid 被删除时,会有 12 个月的禁用期!
解决办法:
已经删除的用户的uid 存储在
/etc/security/ia/ageduid
#cd /etc/security/ia
#chmod 777 ageduid
#vi ageduid
  删除该文件中的所有的内容,然后
#chmod 400 ageduid

就可以重新用 该uid 创建用户了!!!

另:/etc/default/userdel 文件中定义了 uid 被删除以后可以重新启用的期限(以月为单位)

 meteor06 回复于:2003-08-14 09:45:10
不错,加精

 unixgood 回复于:2003-08-14 17:12:59
真的不错,收下啦!

 什么都不懂 回复于:2003-08-14 17:49:53
好东东,又多学了一点。

 ycguolin 回复于:2003-08-15 10:29:06
好东西,收藏。

 saintdragon 回复于:2003-08-15 10:54:16
虽然我已经从别处知道了,但我仍然要为楼主叫好

原文转自:http://www.ltesting.net