为何我的导出文件只有500K,导入时却占用了700M的空间?

发表于:2007-06-22来源:作者:点击数: 标签:

   
  软件环境: 1、Windows NT4.0+ORACLE 8.0.4
  2、ORACLE安装路径为:C:\ORANT
  
   解释原因: 1、一般情况下,用export导出来的dmp文件中,包含表的storage信息,
  

    如果导出的是一个很大的表,比如有1000万条记录,则此表的storage默认初始大小已达到上百兆,
  
    这样如果你使用rows=n选项,即使导出来的dmp文件大小只有不到一兆,
  
    导入时,系统会按storage默认初始大小来分配表空间,所以一下就占用了很多的空间,
  
    如果剩余表空间不够,并且没有设置成自动扩展(数据文件),还会发生导入错误。

原文转自:http://www.ltesting.net