安装SCO Openserver5.0.5下的Sybase11.0.3。

发表于:2007-06-22来源:作者:点击数: 标签:
一、建立Sybase用户及组 二、在aio及suds文件中查看组情况 三、设置共享内存 四、设置环境变量 五、授权 六、MountCD-ROM 七、执行sybload-D 八、unmountCD-ROM 详细介绍如下: 一、建立Sybase用户及组 1.建立Group 1以root的身份登录; 2运行scoadmin scoad

   
一、建立Sybase用户及组
二、在aio及suds文件中查看组情况
三、设置共享内存
四、设置环境变量
五、授权
六、Mount CD-ROM
七、执行 sybload -D
八、unmount CD-ROM
详细介绍如下:

一、建立Sybase用户及组
    1. 建立Group
       1> 以root的身份登录;
       2> 运行scoadmin
          scoadmin     Aclearcase/" target="_blank" >ccount Manage      Group     Add new group
          Group Name: sybase
          Group ID: 100
       2. 建立User
          scoadmin     Account Manage     Users     Add New User
          Login: sybase
          UserID: 201
          Comment:
          Login Shell : sh
          Networked Via:
          Home Directory: /u/sybase
          Login Group: sybase                  Change Group Membership...
          在 Change Group Membership...下设置:
          Login Group: sybase
          Nember of:  sybase
二、在aio及suds文件中查看组情况
    aio及suds所在的目录为:/etc/conf/sdevice.d
       aio及suds的原文件可能是:
        aio    N      0    0   0   0   0    0    0    0 
       suds    N      1    0   0    0   0    0    0    0   
       所做的修改是将aio 及suds后的“N”改为“Y”
        aio    Y      0    0   0   0   0    0    0    0 
       suds    Y      1    0   0    0   0    0    0    0   
       保存文件。
    若在安装SCO时将安装大型数据库选为YES,次文件不动.
三、设置共享内存
    1。运行scoadmin
    2。在Kernel Manage中的Parameters设置
       Parameters--Tune Parameters 第16项Shared Data中进行设置:
       设置的共享内存数为本机内存的75%。
    3。重新链接核心。Kernel [Relink Kernel]
四、设置环境变量
     设置环境变量在 /.profile 文件中加入:
     SYBASE=/u/sybase   按配置SYBASE的选项
     DSQUERY=SYBASE
     export SYBASE
     export DSQUERY
五、导出授权
    导出授权是执行: suds_ctrl -a 100命令!
    首先是编辑文件:/etc/rc2.d/S90suds
     vi S90suds  (文件名第一个’S’大写)
        suds_ctrl -a 100  (100 表 sybase 组的ID)
     保存退出
     运行 suds_ctrl –a 100
     重新启动计算机
若安装SQL Server 过程中boot server时出现下面错误(可检查errorlog文件):
   1>   若不导出授权,在安装完毕后,用sybinit配置时会报错:
         Boot the SQL Server Waiting for
         Server ‘SYBASE8’ to boot…
         SERVER ERROR:
         Failed to boot Server ‘SYBASE1’
  2>   ulinitspinlock:allocate mutex lock failed
       则是因为在执行suds_ctrl时SYBASE用户组的组号不对,重新   执行
       suds_ctrl即可。
六、Mount CD-ROM
       运行scoadmin
       >Filesystems     Filesystem Manager     Mount     Add Mount Configuration
            Local
               Device File: /dev/cd0
               Mount point: /cdrom  //用户首先在根目录下建立需Mount的目录
               Description (optional):
            ------------------------------------
               Filesystem Type: ISO9660
               Access Mode: Read-only
               Can Users Mount :No
         下一步:
         Mount Options:     Advanced Options...
                      Convert Filenames to Lowercase: Yes  (No 改为 Yes)
                      Show Hiddenfiles: Yes
                      Show File Version Numbers:NO
七、执行 sybload -D
     1. 以sybase的身份登录;
     2.运行sybload -D
       譬如:sybload 文件在/cdrom/software/sqlsvr下:则:
          #pwd
           /usr/sybase
          # cd
          # /cdrom/software/sqlsvr/sybload -D 稍后...
                    SYBLOAD - Product Distribution Program
                                 Sybase (c) 1994
Current directory is "/sybase_install".
Is this the correct directory for installation?
If so, please enter 'y' or 'Y':  y  // Sybase 安装在/usr/sybase目录下
Is this a Local or Remote installation, as defined in your Installation Guide?
Please enter L for Local or R for Remote.
> l                        // L—本地,R—远程
Please enter the full name of the disk file of the global archive:
> /cdrom/sybimage
You specified /cdrom/sybimage for the media device.  Is this correct?
please enter 'y' or 'Y' to continue:  y
Please enter your Customer Authorization String, letters only:
; BKBYBK BKBYBK SOZKHH BYBKBY TELNGX DECO
Sybase Products available for installation:
Product No.  1:  SQL Server, IRIX 5.3, 11.01
Please enter the Product Numbers that you wish to install, one per line.

Terminate your entries with a blank line.
> 1
> 
The following products were chosen for installation:
Choice No.  1:  Sybase SQL Server, IRIX 5.3, 11.01
If this list is correct as shown,
please enter 'y' or 'Y' to continue,
             'q' or 'Q' to quit,
or any other character to make another set of choices:  y
    Positioning Media For Loading - Please Wait.
x ./bin/buildmaster, 296160 bytes, 579 tape blocks
x ./bin/charset, 466109 bytes, 911 tape blocks 
x ./bin/dataserver, 2413163 bytes, 4714 tape blocks
x ./bin/diagserver, 10105628 bytes, 19738 tape blocks
八、unmount CD-ROM
         安装完毕,运行scoadmin
         >Filesystems     Filesystem Manager
         选中/dev/cdrom
         Mount     Remove Mount Configuration...

原文转自:http://www.ltesting.net