• 软件测试技术
  • 软件测试博客
  • 软件测试视频
  • 开源软件测试技术
  • 软件测试论坛
  • 软件测试沙龙
  • 软件测试资料下载
  • 软件测试杂志
  • 软件测试人才招聘
    暂时没有公告

字号: 小 中 大 | 推荐给好友 上一篇 | 下一篇

AIX学习读书笔记

发布: 2007-6-08 22:43 | 作者: seanhe | 来源: | 查看: 24次 | 进入软件测试论坛讨论

领测软件测试网

MILY: 宋体; mso-bidi-font-size: 10.5pt">191读书笔记 (一)

第一章 认证概述 
认证考试目标 
1.
安装和配置 
2.
问题解决 
3.
系统和用户的维护 
4.
通信 
5.
系统管理 
6.
安全 


第二章 系统启动问题处理 
本章讨论你在系统初始化阶段所遇到的启动的进程和常见的问题,她也覆盖了那些与启动过程有关的常用命令。 
学习完这章你可以掌握如下内容: 
理解启动的基本过程,能够执行正常的系统关机 
确定和控制包含再启动过程中的设备 
解决启动的问题 
理解和记住基本LED错误代码 
2
.1这章的命令 
alog 
维护和管理log文件 
cfgmgr 
配置设备和安装设备软件到系统 
last 
显示所有的在/var/adm/wtmp中的login和logout 
bootlist 
显示和改变系统有效的启动设备列表 
uptime 
显示系统开机时间 
mpcfg 
使具有root权限的用户管理服务信息 
shutdown 
关闭系统 
2.2 
启动过程 
在系统启动的过程中,系统将检测硬件,load和运行操作系统,配置设备。为引导操作系统,下面的资源是要求的: 
1.
在机器开机和reset后能够load的引导镜象 
2.
访问 根目录和/usr目录 
系统启动的三种方式: 
1.
硬盘引导 默认的引导方式 
2.
无盘网络引导 
3.
维护引导 在维护模式下,系统管理员可以执行类似安装新的系统,更新软件,运行诊断检查。 
在硬盘引导过程中,系统安装时生成在本地硬盘的引导映象被发现,在引导过程中,系统配置在机器中发现的所有设备,初使化系统操作要求的其他基本软件如逻辑卷管理,在最后文件系统被mount,准备使用。 
无盘网络启动也一样,但信息是通过网络访问获得。 
系统引导过程分三个阶段 
1.read ros init phase 
在这个阶段,检查主板,load ros搜索 bootlist ,当bootlist被发现,读取启动映象到内存,系统初使化开始。 
2.base device configuration phase 
在这个阶段所有的设备被配置通过cfgmgr 
3.system boot phase 
在这个阶段,所有的lv vary on ,页面文件开始,/etc/inittab 文件执行。 
2.4.1 
使用alog 命令 
通过alog命令可以跟踪启动过程,发现问题, 他读取标准的输入,写入标准的输出,同时copy输出到固定大小的文件,rc.boot(/sbin) 通过alog命令将启动信息重定向到/var/adm/ras/bootlog文件中,如果系统有问题,可以通过单用户模式,察看log信息。 
-f logfile 指定log文件名,如果该文件不存在将创建,如果alog命令不能写到 文件中他将写到 /dev/null 
-L 
列出当前的log类型,如果-L 和-t 同时使用,将列出log类型的属性值 
-o 列出文件内容 
-q copy标准的输入到logfile 
-t 标示一个log文件类型 
2.4.2 cfgmgr 
命令 
cfgmgr
命令配置设备,随时安装设备软件到系统 
-f 说明cfgmgr命令运行在第一phase configuration rule 该参数在系统启动后无效 
-i device 指定安装介质路径 
-l name 指定单独配置该设备名及子设备 
-p phase 指定cfgmgr命令运行的阶段 
-s 指定cfgmgr运行在phase 2 configuration rule 
cfgmgr 
命令配置设备并可选择将设备软件安装在系统中。要配置的设备由“配置规则”对象类控制,此对象类是“设备配置”数据库的一部分。每条配置规则指定三项: 
• 要运行的可执行程序的全路径名 
• 何时运行程序(与其它规则有关) 
• 在哪个阶段运行程序 
在系统启动过程中,cfgmgr命令配置所有的对使用系统必须的设备,系统启动包括二个阶段: 
phase 1 
当内核读入系统,boot file 初使化,phase1开始,-f参数 cfgmgr运行所有的phase 1 规则,配置基本的设备 
phase 2 
-s参数 
cfgmgr
命令重新组织了configuration rule 的三个阶段 
phase 1 
phase 2 
(normal boot) 
phase 3 
(service boot) 
如果cfgmgr命令没有但任何参数,默认是运行phase2 规则,只有在用-p指定时才运行phase 3 的规则。 
Cfgmgr 
-v 与 alog -t boot -o 相似 
2.4.3 last 
命令 
- number 显示的输入行数 
name 
指定用户名 
terminal 
指定终端 
/var/adm/wtmp /var/adm/sulog /etc/security/failedlogin 
2.4.4 bootlist 
命令 
normal boot list 
他指明当系统正常启动时boot devices 的位置 
service boot list 
服务引导列表 
previous boot device 
前一引导设备列表 
both 
如果指定了 both 关键字,会显示常规引导列表和服务引导列表,或者如果正在进行改变,它们将被设置至设备的同一列表 
-m 模式 normal, service, prevboot,both 
-f 指出从文件读取设备信息 
-o 显示bootlist 和 -m 使用 
-r 表示在任何改变后是否显示bootlist 
-i 指出bootlist无效 和 -m 使用 
2.4.5 uptime 
命令 
显示系统已经运行多久 
2.4.6 mpcfg 
命令 
管理远程维护服务信息。 
2.4.7 shutdown 
命令 
-d 把系统关闭从分布式转换到多用户模式 
-F 快速关机 
-h 关机 
-i 交互式模式 
-k 使 shutdown无效 
-m 到单用户模式 
-r restart 
-v 关机 
/etc/rc.shutdown
脚本 可以在shutdown 命令执行前运行, 
2.5 
启动问题解决 
2.5.1 
系统无法启动 
如果你不能引导系统,第一步要访问系统查看错误的可能原因。 
访问系统: 
打开所有外设,开机从安装介质引导 
插入第一张盘 
按系统键 F5 或 5 
2.5.2 problems with installtion media 
2
.5.3 常见的led错误代码及恢复操作 
led 201 boot image 
破坏 
访问 rootvg 
检查 / 和 /tmp 目录,如果已满增加空间 
使用 lslv -m hd5 确定boot disk 
重建 boot image 使用 bosboot -a -d /dev/hdiskn 
检查error log 中的 checkstop errors 
关机或重起机器 
LED 223
-229 无效的boot 列表 
起机 按 F5 
如果显示正常,使用normal mode ,按step 3,如果没有得到提示到 step 4 
登陆,使用bootlist 改变引导列表,然后shutdown 或restart 
访问rootvg 
使用lslv -m hd5 确定boot disk 
改变引导列表 
Shutdown restart 
系统 
LED 551
,555,557 文件系统和jfs log 被破坏 
访问rootvg 在mount file systems 前 
Fsck
当前的文件系统 
使用 /usr/sbin/logform /dev/hd8 format jfs log 
Lslv 
-m hd5 确定 boot disk 
Bosboot 
-a -d /dev/hdiskn 重新创建boot image 
LED 552
,554,556 super block corrupted or corrupted customized odm database 
访问 rootvg ,fsck 文件系统 
如果fsck指出block 8错误,使用如下命令 
dd count=1 bs=4k skip=31 seek=1 if=/dev/hdn of=/dev/hdn 
3
.重建jfs log logform /dev/hd8 
4
.如果问题解决 stop 
5
.损坏,restart system 访问rootvg 
Mount / 
和 /usr mount /dev/hd4 /mnt mount /usr 
Copy 
系统配置到备份目录 mkdir /mnt/etc/objrepos/backup cp /mnt/etc/objrepos/Cu* /mnt/etc/objrepos/backup 
从RAM file system copy 配置 cp /etc/objrepos/Cu* /mnt/etc/objrepos/ 
Umount all 
确定boot disk 
保持干净的 ODM到boot lv savebase –d /dev/hdiskn 
Reboot ,
如果系统仍不能起来,reinstall bos 
LED 553 /etc/inittab file corrupted 
访问rootvg ,mount所有的文件系统 
检查 / ,/var,/tmp空间 
检查/etc/inittab 文件 
执行下面文件检查问题 
/etc/environment ,/bin/sh,/bin/bsh,/etc/fsck,/etc/profile,/.profile 
shutdown , reboot

延伸阅读

文章来源于领测软件测试网 https://www.ltesting.net/


关于领测软件测试网 | 领测软件测试网合作伙伴 | 广告服务 | 投稿指南 | 联系我们 | 网站地图 | 友情链接
版权所有(C) 2003-2010 TestAge(领测软件测试网)|领测国际科技(北京)有限公司|软件测试工程师培训网 All Rights Reserved
北京市海淀区中关村南大街9号北京理工科技大厦1402室 京ICP备2023014753号-2
技术支持和业务联系:[email protected] 电话:010-51297073

软件测试 | 领测国际 | ISTQB | ISTQB官网 | TMMi | TMMi认证 | 国际软件测试工程师认证 | 领测软件测试网