本人在使用SCO OpenServer 5.07操作串口上的明华澳汉RD-EB-MX读卡器时碰到了一个难题!
我是按照以下步骤操作的:
1、disable /dev/tty1a;
2、操作串口1上的读卡器(简单的打开关闭操作);
3、返回错误:-136,通信错误。
虚拟机、台式机、笔记本都试过,始终不行。
困惑中......等待救星!!!(已经解决,谢谢各位的帮忙!)
| xiechq 回复于:2005-05-31 18:22:25 |
| 读卡器?disable不是禁止吗?(不知道瞎问的) |
| xuzheng 回复于:2005-06-02 11:02:04 |
| speed 是否正确???是否打开了端口?? |
| sgmj 回复于:2005-06-03 08:18:25 |
| 打开?如何打开端口啊? |
| zhyesno 回复于:2005-06-03 08:43:10 |
| [quote:6db57d0e62="sgmj"]打开?如何打开端口啊?[/quote:6db57d0e62]
:shock: 那你怎么操作啊? 程序里open打开啊. |
| sgmj 回复于:2005-06-07 11:04:27 |
| 谢谢各位的帮忙,问题已经解决!是一个自动打开串口的函数在SCO UNIX下不管用导致的!具体原因是SCO UNIX上speed必须与系统设置的相同,而其它系统如linux、windows可以不与系统设置的一致! |
延伸阅读
文章来源于领测软件测试网 https://www.ltesting.net/









