• 软件测试技术
  • 软件测试博客
  • 软件测试视频
  • 开源软件测试技术
  • 软件测试论坛
  • 软件测试沙龙
  • 软件测试资料下载
  • 软件测试杂志
  • 软件测试人才招聘
    暂时没有公告

字号: 小 中 大 | 推荐给好友 上一篇 | 下一篇

一个Jsp初学者的学习过程(二)

发布: 2007-7-04 13:34 | 作者: admin | 来源:  网友评论 | 查看: 12次 | 进入软件测试论坛讨论

领测软件测试网 一个Jsp初学者的学习过程(二)

TheUnforgiven


第二章 轻度接触server.xml

现在开始编写我们的第一个.jsp文件了,代码如下:
----------------------------------------------------------------------------------
<%@ page contentType="text/html; charset=gb2312" language="java"errorPage="" %>
<%
out.print("日本人应该被彻底消灭");
%>
----------------------------------------------------------------------------------
这个文件是在页面输出一句话,你甚至可以用记事本来编写,但主要的问题是,这个文件(比如叫test.jsp)它放在哪里。Tomcat的默认目录好象是D:\Tomcat 5.0\webapps\jsp-examples,早期4.1版本目录是examples,把这个文件放到jsp-examples下,开启Tomcat服务器,在地址栏输入:http://ringz:8080/jsp-examples/test.jsp。

现在要说的问题是:我不想用8080这个端口,直接用http://ringz/jsp-examples/test.jsp多好啊。这首先要取决你的80端口是否被占用,一般来说你的机器里没有安装IIS或者停掉IIS服务,80端口就可以使用。具体的修改方法如下:打开这个文件——D:\Tomcat 5.0\conf\server.xml,你会找到这样一段代码:
<Connector port="8080"
maxThreads="150" minSpareThreads="25" maxSpareThreads="75"
enableLookups="false" redirectPort="8443" acceptCount="100"
debug="0" connectionTimeout="20000"
disableUploadTimeout="true" />
把port="8080"改成port="80",保存文件,重启Tomcat服务器,如果能够启动,说明可以使用80端口了;而要是Tomcat启动窗口一闪即关掉,就说明80端口已经被占用了(这个判断的前提是该server.xml文件没有错误,如果有其他错误的话,比如少一个“/>”,也会这样)。按照此方法你可以改成其他闲置的端口,比如说,给我们做软件的公司在测试的时候使用的是7988端口。除了80端口,其他端口都要在地址栏注明,80之所以不用是因为它是http协议的默认端口。
接下来的问题是:我不想把写好的.jsp文件放在D:\Tomcat 5.0\webapps\jsp-examples下怎么办?这同样需要修改server.xml文件:假如你的.jsp文件都放在e:\MyJsp下,则在该文件的<Host></Host>之间加入这样一段代码:<Context path="/MyJsp" docBase="e:\MyJsp" debug="0" reloadable="true" crossContext="true"/>(注意要和文件名的大小写要一致)。这样你可以在地址栏输入http://ringz/MyJsp/test.jsp(同样要注意大小写要一致)来运行这个文件。如果改成:<Context path="" docBase="e:\MyJsp" debug="0" reloadable="true" crossContext="true"/>,这样在地址栏里输入http://ringz/test.jsp就行了。
你感兴趣的话可以看看只输入http://ringz后页面是什么样的。
现在你可能会有这个想法:我的一个系统(或者叫一个站点)有一个固定的入口文件,比如叫login.htm,我希望只在地址栏输入http://ringz就可以打开这个文件,这怎么办?这个我们可以通过修改和server.xml处于同目录下的web.xml文件来实现:一般在这个文件的最下有这样一段代码:
<welcome-file-list>
<welcome-file>index.html</welcome-file>
<welcome-file>index.htm</welcome-file>
<welcome-file>index.jsp</welcome-file>
</welcome-file-list>
你只需要将其中一个改成<welcome-file>login.htm</welcome-file>就行了。对于这个web.xml文件我们以后还会提到,就先不多说了。

记住一点:server.xml或者web.xml文件在修改后一定要重启Tomcat服务器才行。

文章来源于领测软件测试网 https://www.ltesting.net/


关于领测软件测试网 | 领测软件测试网合作伙伴 | 广告服务 | 投稿指南 | 联系我们 | 网站地图 | 友情链接
版权所有(C) 2003-2010 TestAge(领测软件测试网)|领测国际科技(北京)有限公司|软件测试工程师培训网 All Rights Reserved
北京市海淀区中关村南大街9号北京理工科技大厦1402室 京ICP备2023014753号-2
技术支持和业务联系:[email protected] 电话:010-51297073

软件测试 | 领测国际 | ISTQB | ISTQB官网 | TMMi | TMMi认证 | 国际软件测试工程师认证 | 领测软件测试网